"Error 315000" won't display achievements

Bug Report
Since the 1.0.5 patch, whenever I try to bring up the achievements UI (inside a game or at the menus, either way), I get blank panes and the error message:

There was an error retrieving achievements data. (Error 315000)

Since I don't see any other complaints about this in the last few months, I assume there's something wrong with my account in particular, but the ticket system says I should just post it publicly, so here it is, heh.
Still can't view my achievements. If it helps, here's the error that's being generated in D3Debug.txt when I try to bring up the Achievements UI (outside of game in this case):

2012.10.29 17:34:07.129929200 >>> UIAchievements::sSnapshotResolved error=315000 Player is not connected or there is an issue with the service. Please try again. (Error 315000)
2012.10.29 17:34:07.130135000 >>> Nephtis ---------------- ModalNotificationManager::SetOkNotification: There was an error retrieving achievements data. (Error 315000)

It happens in and out of game, with all characters. I'm a bit of an achievement (obsessive), so not being able to keep up with them, or know if they're being updated when I kill one of the newly-available bosspacks or whatever, is a something of a downer.
Same problem here, no response...
Still can't view my achievements. I'm not really clear on protocol here. In the absence of notice/feedback/fix do I assume it's just languishing in some poor overworked programmer's "in" pile and definitely on track to be looked at someday, or is this more of a squeaky wheel gets the grease situation?
Additional info. I installed the game on another machine and logged in with my account and the achievements load properly (and are up to date with stuff I've "achieved" since it stopped loading on my main pc, so I assume the lack of communication with that data on the server is one-way).

So apparently it's something in the local install that was broken by the 1.0.5 patch for me. Nice to know I can work around it, even though I'll have to blow several hours getting it reinstalled. I suspect whatever bug caused it to break during patching in the first place is still something that should be tracked down and fixed, so hopefully this info is marginally useful in that endeavor.
have the same problem. i already tried resetting my password, and trying to open the game using another admin account. several times. none of these work. can anyone help?
I too have the same problem.

I can see the achievements on my old computer (including the ones I have achieved on my current computer) but get the same error message 315000 on my new one.

I have tried re-installing but the problem remains.

Help please!
I finally got around to sinking the 4+ hours of computer time necessary to uninstall/reinstall the game, and it did not correct the problem (I get the error when logging in on one machine but not the other, same battle.net account on both).

I also deleted and forced the game to reconstruct the directories:
.../Application Data/Battle.net/
.../My Documents/Diablo III/
and this also did not fix it. I tried to do the same with the
.../Application Data/Blizzard Entertainment/Battle.net/
directory, but that dropped me into the whole "error 14009" authentication problem, so I backed it out.

So unless I'm missing some other place where possibly-hosed settings might be living, this is a server-side problem, possibly related to which IP I'm logging in from, or some computer-identification functionality, or something else, that makes the server deny one machine access to the achievement information, but gives the information to the other one.

I'm open to suggestions on anything else I can try on my end. Or, you know, any kind of feedback whatsoever as to the status of this bug on Blizzard's end, if it's even been accepted as a bug of sufficient priority to have a status at all, heh.
Just thought I'd drop an update that my account is still plagued with this glitch, coming up on 8 months later. I only get the urge to play this game every once in a while anymore, but not being able to track achievement progress (particularly the uniques list) kills my interest pretty fast when I do crank it up. I tried purging the various caches again, with the same results I noted in December.

Are there any new potential solutions floating around these days?

Join the Conversation

Return to Forum