Error 3003 from RMAH (6th day now)

Technical Support
Prev 1 2 3 4 9 Next
have spoken to several people over msn and they are affected by this also as they also use paypal on the AH. a lot of them dont even go on the forums so its not being voiced on here as much as it would if they did. Hope more people here voice it as its affecting many
Hi, I have the same problem, 3rd day running. Looked ALL over the forums for a blue post regarding this, but none so far. What's happening?
happening to me 2 :(
I love how some customer support people admit they have a problem and its being worked on, some blame our computers for the problems, other say we need to clear the cache and others dont even get a reply to the tickets

This is a joke
Worst answer from their CS. Obviously dint even read my ticket or know what 32105, "Due to heavy laod.." error is.

Greetings!

Thank you for contacting us today! I will do my best to assist you. I see that you are having trouble with the Real Money Auctions. Customer service is limited to what kind of support we are able to provide for the Real Money Auction House. I do see that those transaction have failed, however, the failure error message that the payment could not be verified is on part of the buyer, not the seller. You should be able to sell those items as long as the buyer's funds can be verified.

Let us know if you still require further assistance by replying to this ticket. However, if I have answered all of your questions, please click on "Mark as Resolved."

Thanks again for your business and we hope you have a wonderful day!

Sincerely,

Account & Technical Services Rep Ozmeluna
Customer Services
Blizzard Entertainment
www.blizzard.com/support
No resolution for me either. So bump.
bump
Same for me 3rd day, interesting fact, I wasn't sure if it was just me or not, I logged into my mates account and could post items on rmah, not sure cause he hasn't got the a patch or not, but then when I went on my account same thing. Due to heavy load blah blah pretty sure it's a regional problem haven't seen 1 American have a problem. Bump
BUMP!

From Australia - same problem 4th day running.......

Please Blizzard, do not discriminate non American Regions by delaying fixes affecting other regions!
BUMP!!

Same here, From Australia. Started on the 25th for me.

Support tickets back and forth. I called and emailed paypal and everything is fine from their end. Blizzard replied to me that I have to call them. This morning I call (29th) spoke to an awesome Account & Technical Services Rep named Andy G.

He closed existing ticket and opened a new one. He told me the issue has been escalated and that if I have any more info to reply to the new ticket. Done a fresh Windows 8 install, checked host file, deleted and re-added PayPal Acc to battlenet and nothing worked. Posted back to the ticket and some other idiot replies with:

Any questions about adding funds, transferring funds, or checking available funds on your PayPal account need to be directed to PayPal support. Blizzard Customer Support cannot assist with PayPal account inquiries of any kind. For general information, please review our PayPal FAQ: http://us.battle.net/support/en/article/paypal-faq.

I explain to the guy that I have already called and my issue has been escalated and he replies sending me to this thread. I message back saying "Yes I have seen the thread and called customer support. How about you guys provide a solution now? Is that not what I opened a ticket for?"

OK That’s where I am at :) on the other had I guess that Blizzard is not to interested in taking our money after all otherwise this issue would of been fixes ages ago. What happens to all the items I purchased and the transactions failed? Do we get compensated?
bump
bbbb
I have the same problem. Bumping this for great justice. I have an item that started at 80 dollar value and since have fallen to 50 dollars since the patch opened. It's depreciating by the day and I still cannot post it up to the RMAH. CS has told me their looking into it days ago.
They need to sort this out asap.
Bump, awaiting for their immediate hot fix on this....
Bump, awaiting for their immediate hot fix on this....
Same here from NZ. Thought it was just my account, but looks like they still haven't fixed RMAH. They only just got it fun to play again and now they can't get the ah right....
my reply from customer service was equally as awesome / expected.

Seriously its a joke..
Same issue for me here except it is buying items from RMAH using my Credit Card

**ERROR 3003 - FAILED TRANSACTION**

This coincidentally started occuring since patch 1.05.

I have made several phone calls and submitted tickets to customer service.

The first 2 times I was told by Customer Service that there was no visual blocks or errors on my card and I was directed to contact my card issuer/ financial institution, which I did and both times I was told by my card issuer that there is nothing wrong with my card or account at their end.

On Saturday I rang back Customer Support to advise them that my bank gave the all clear on their end and that the problem must be at the Point Of Sale ie.- Blizzards' End. The Customer Support Person "Matt" advised me that he again can't see anything and was thinking there was a possible fraud issue with my account and that he would direct this issue to the Blizzard Fraud Department for further investigation and that I would receive a call or e-mail atleast today (Monday) from the Fraud Dept. advising the outcome. (I thought I was getting somewhere!)

Well no e-mail or call today so AGAIN I contacted Customer Support, this time the Rep. had me inspect my modfied host file as per https://us.battle.net/support/en/article/checking-your-windows-hosts-file. We ran through this and it made no difference.

He stated the following:

"Blizzard does not seem to be aware of any issue regarding the RMAH and payment. He was unable to do anything further than to report the problem to the relative Department." He also stated "that the Problem seems to be exclusive to Australian Players and that he had the same issue a few calls back from another frustrated Australian player".

Blizzard what more can we do to get this issue/bug fixed?

I feel the game is passing me by so I may as well sell up and quit!

I am missing out on items I want to purchase and my friends are moving ahead in the game whilst i'm stuck.
Bumping this RMAH issue thread!
Happened since 1.05a patch and no fix until now!
FACK!

Join the Conversation

Return to Forum