Excessive Screen Tearing

Technical Support
I'm not sure if screen tearing is the proper term for what is occurring, but, recently (maybe 3/4 days ago) the game started experiencing blips of coding popping up in the upper left portion of the screen. These blips would appear and disappear fairly rapidly, longest being around 7-10 seconds with the shortest being less than a second. Occasionally the screen will go entirely black with just the coding appearing in white lettering. These blips would occur while i was playing the game, browsing the AH, paused, switching between windows, or simply afk.
I tried to resolve the issue by reducing the graphics settings (which were already fairly low due to playing off a laptop) and this seemed to have no effect. I also toggled the vertical sync in the options menu without seeing any difference. This did not used to occur, i played for quite a few months without having any issues and would very much like to stop this from occurring anymore.
Farmerk,

Read through these threads and see if you're seeing the same or similar issue reported there in the screenshots.

http://us.battle.net/d3/en/forum/topic/6019512300?page=1

http://i50.tinypic.com/jkun0l.jpg

and this thread: http://us.battle.net/d3/en/forum/topic/5745446736

http://i.imgur.com/Kej7r.jpg

If so, I'd have to recommend swapping out the video card first.
It didn't seem to match up with any of these threads. i was able to read some of the text that showed up, seems to change around, but when i read it it said :
Handle event "auth not valid"
Handle event "auth not valid"
Handle event "auth not valid"
Handle event "auth not valid"
or something similar...
I tried switching off of full screen so that i could get a picture of it, and it seemed to stop occurring, even when switching between windows, which was when it seemed to always occur when i played full screen. Since im using a laptop, i know the graphics card is off limits for upgrade, is the video card able to be upgraded w/o replacing the entire laptop? and i have only been experiencing this issue for the past few days, could it have suddenly gone out?
Farmerk,

No, you won't be able to swap out the video on a laptop unless it's a high-end gaming model built with that capability.

It would help a lot if I could see what you're referring to via a screenshot.
Unlike in those threads the lettering i am seeing is limited to the upper left section of the screen, occurs in an ordered format similar to coding (as i showed above), and usually on a blacked out area of the screen or entire blacked out screen.
Any advice on how to acquire a pic? only method i am aware of is paint and print screen, which i cant use on full screen mode as it takes a pic of everything but the game... and it seems the problem is only occurring on full screen mode
Farmerk,

Can't you use the in-game screenshots? Just hit the Print Screen key and it's saved to a Screenshots folder in the My Documents\Diablo III folder.

Then just upload it to a hosting site and post the link.
I wasn't aware of this feature, I have at least 1 decent pic now, what is a good hosting site?
I think i managed to get a link going, the text is usually a lot more complex than this and varies with where i am at/what i am doing in game, but here is an example. let me know if you are able to view it, as this is my first time uploading photos and posting links and such.
http://i963.photobucket.com/albums/ae115/surferboyfarmer/Screenshot038.jpg
http://i963.photobucket.com/albums/ae115/surferboyfarmer/Screenshot195.jpg
Farmerk,

Are you running Linux?
nope -
Sony Vaio using Windows 7 Home premium. i5-2400M, 2.3 GHz processor with 4 GB ram and 64 bit operating system
Farmerk,

Are you running the game in a compatibility mode? Check by right clicking the icon you use to start it and selecting Properties, then check the Compatibility tab. No options should be checked on that page.
nothing is checked under compatibility
Farmerk,,

It looks like it might be something to do with Agent after doing a little more digging.

Could you try what's described in the following two article please?

https://us.battle.net/support/en/article/deleting-the-battlenet-cache-folder-pc

https://us.battle.net/support/en/article/deleting-battlenet-tools-folder-pc
I didnt find a Blizzard Entertainment folder when trying to clear the cache, and i don't have a "Battle.net" folder that the directions in the deleting the battlenet tools folder describe, rather, I have a "Bnet" folder (this folder, once opened, contains an application extension titled "Battle.net.dll") , is this the same?
Farmerk,

What operating system are you using?
Sony Vaio using Windows 7 Home premium. i5-2400M, 2.3 GHz processor with 4 GB ram and 64 bit operating system
Farmerk,

Did you take the necessary steps to view "hidden" folders?

https://us.battle.net/support/en/article/showing-hidden-files-and-folders-pc
yep
Farmerk ,

Are you sure you're looking in C:\ProgramData ? Sounds like you're in the game folder instead which is the wrong place.

Join the Conversation

Return to Forum