Friend cant join me, I can join him

Technical Support
Basically what the topic says, I can join my friend - no problems at all. But when I invite him to my game he gets stuck in the 'menu' where you see the partymembers, all buttons are grayed out (AH etc..) and what I see on my screen is his portrait in the top left corner, a little grayed out with an hourglass, nothing happens.

He's tried starting the game as adminstrator and we're really out of options here. Ofc we can play together in the sense that I join him but it's pretty annoying that I can't invite him to my games nor link items, it's a problem that clearly needs to be solved.

Any suggestions?
Same problem though its me who cant join partys
Seeing as there are others with the same problem, are there any soloutions to this? Would greatly appreciate any sort of answere that either tells me what is causing the problem or how to solve it!
Any luck? Similar problem here, however, I can't join any game ...

Join the Conversation

Return to Forum