Adventures in Win 8, and messy workarounds.

Technical Support
So last night I decided to try and install D3 on a freshly installed Windows 8 Enterprise machine, but I ran into a few big problems. I came up with a workaround that requires the use of another machine running Windows 7 or earlier that already has or can have D3 installed on it. This may not work for everybody, and it may not solve your particular issue with the game running on Win 8, but this is my experience and I wanted to share it with anyone else who may have run into the same issues that I did.

The 2 problems I ran into were: 1. Trying to download and install the game timed out with a "failed to download a required installation file" error, followed by a URL. I was able to pull up that URL in my web browser just fine. Messing around with firewall settings and such didn't make a difference. I ended up going to another machine I had that was running Windows 7, copying the Diablo III folder over to my Win 8 machine(C:\Program Files (x86)\), and then relaunching the installer. This time I didn't receive an error and was able to launch the game.

Problem 2. I was not able to log-in. After a minute or so of staying stuck on the Authenticating, I was given the error "There was a problem with an authentication module". Again, firewall settings and such didn't make a difference. The same Windows 7 computer on the same network could sign in just fine. I tried running in compatibility mode for Windows 7 and it worked! I was able to log in and play. I didn't have any problems from here, and the game worked just fine!

So in short, to fix the problem with not being able to download the game, I pulled over a copy of the Diablo III folder from my Windows 7 machine to my Windows 8 machine. I was unable to copy the folder directly into the C:\Program Files (x86) folder though. I had to copy it to C: on the Win 8 machine, then copy it into Program Files (x86). Note, if you're on 64 bit Windows, Diablo III will be in Program Files (x86).

Another note, I'm sure that if I were to have installed from the DVD media, it would have installed just fine. For some reason the installer just didn't want to communicate with bnet.

I then launched the installer to do whatever it needed to do with the registry, create links and stuff like that. It was able to launch the game but again, I was unable to log in.

Right-clicking on the shortcut, going to properties, compatibility and setting it to run in Compatibility mode for Windows 7 seemed to work and got me up and running.

Final observation: I should have tried to run the installer in compatibility mode for Windows 7 but didn't think about it until I was trying to run the game itself. I wonder if that would have prevented this whole mess in the first place?

tl;dr: I know that feel.

Join the Conversation

Return to Forum