"Unexpected Error" causes crash on startup.

Technical Support
It happens every time I attempt to launch, just after hitting "Play" on the launcher. It gave me a little window to tell me what I was doing, and the following Report ID that I'm supposed to give you:

F7195914-963D-4E0A-BBC2-9DE6A481F667

The Report ID changes every time I try to launch.
Mand,

Your crash info indicates a patch was applied incorrectly or one or more game files are corrupted. The easiest way to resolve it is probably to reinstall after first deleting the folders described in these two articles.

https://us.battle.net/support/en/article/deleting-the-battlenet-cache-folder-pc

https://us.battle.net/support/en/article/deleting-battlenet-tools-folder-pc
Getting the same error after installing Diablo III on a new computer. Also installed Warcraft on the same new computer and it is running like a champ.....any suggestions? Fully updated graphics drivers as well.
I tried what you suggested to the OP, same error.

A42B3B1F-743A-4E83-9382-C82760B41288
If you are using the Discord Overlay disable it. It will cause a crash on start up.
Thanks MissCheetah, I do have it though it was only supposed to be active for Warcraft. I will disable it completely just to see if it gets the game to load.
MissCheetah....you ROCK! That fixed it. Though it was only supposed to overlay on Warcraft, it must be staying resident even when I closed WoW.

Thanks for the SUPER fast response!
5B1F4C12-13AA-4058-9C58-DC209B93B2C0 Error report was issued on hardcore setting and easy . hard , expert level , same place every time and find I am unable to get beyond this particular spot .
MightyBeast,

This is due to an issue with your AMD video drivers. Are you using the latest Crimson Edition they have on their support site?

______________________________________________________________
I'm available in the forums Monday - Friday 6:00 am - 3:00 pm Pacific Time,
Feedback? - https://www.surveymonkey.com/s/Omrakos
THANK YOU SO MUCH!, this was causing me so much trouble!
669C8F1F-40B6-4068-8C02-A72F02E12CA1

I got this error code after i walked out of the portal in DESOLATE SAND on ACT II
i was only playing in hard mode
can anyone help me out plz
Same here. Freezes on authentication screen of Diablo.
Windows updates went last night. But nothing else.

Need a crash assistant!
Other games run fine.\

Moved from ATI to Nvidia card recently but had a full weekend of troublefree gaming after that change.
07/12/2016 06:39 PMPosted by eRanikxxxoNe
669C8F1F-40B6-4068-8C02-A72F02E12CA1

I got this error code after i walked out of the portal in DESOLATE SAND on ACT II
i was only playing in hard mode


Like Omrakos mentioned, make sure that you're using the latest AMD crimson drivers as there was an issue with the older AMD drivers.

07/13/2016 06:14 AMPosted by Hadoken
Same here. Freezes on authentication screen of Diablo.
Windows updates went last night. But nothing else.

Need a crash assistant!
Other games run fine.\

Moved from ATI to Nvidia card recently but had a full weekend of troublefree gaming after that change.


"ltc_game32-114279.dll" is where the crash is happening which is part of Raptr and/or Plays.tv. Please uninstall both of those and try again. =)
Hey,

I'm having a similar problem. I've tried all of the troubleshooting items listed in the forum. This is the error code I got. It changes every time.

ECA53F1E-0D88-4870-BE0E-C34D6DA09A15
pavilion lap top ..windows 8 ,upgraded to 10 and nothing special except ' old ' THANK YOU FOR THE HELP ! if I play public not private once past level 60 I can go to all 5 places ,and do riffs, and grater riffs, but just this one section does this to me and its my video card you say most likley
I was running a greater rift and started encountering serious stutter. I reset my computer and restarted and as battlenet attempted to start I got an error message stating:

This application encountered an unexpected error

08D32B70-5D28-4FBF-B626-679A18984EDB
Desolate Sand - Act II crashes every time even though the AMD AutoDetect Program shows:

Your system already has the latest driver installed.

Graphics Hardware:
AMD Radeon HD 8670D

Processor:
AMD A10-6700 APU with Radeon(tm) HD Graphics

Operating System:
Windows 10 Home Edition
64-bit

Random Access Memory:
12.0 GB with 11.2 GB Available to Windows 10.

Reduced the framerate and video size and the same results.

---

The first mobs before talking with the NPC are killable as usual but as soon as the NPC talks then teleports, the screen locks up.

Hope that helps resolve the issue!

>:(
Tried moving to a different way point.

The NPC disappears with no issue.

However as soon as I go back to Desolate Sand - Act 2 the NPC appears then after running back towards the way point... He disappears but as soon as I enter Desolate Sand Map where the crash occurred... the game locks up yet again.

---

I know that this kind of problem can be difficult to find even for us long time Computer Programmers like me. (Nearly 39 years of experience at this point in time.)

If you can consistently reproduce the problem then the problem becomes easier to find.

Here's hope that you guys and gals will find the solution quickly.

"SevenUp"
Age 59 Gamer.
Crimson Edition patch for AMD solved the problem.

Thanks!

:D

Join the Conversation

Return to Forum