System "Stuttering" after patch 1.0.5a

Mac Technical Support
My MBP (July 2011 new) went from running Diablo 3 perfectly on roughly medium-high settings - literally no problems until the patch came out.

Now there is a lag between when I click and when the character does an action. It is not the total stopping of doing any actions, only the slowing down of it. Frame rate is terrible, even with all the settings turned down to low and/or off.

I have reinstalled Diablo 3, optimized my MBP using the blizzard websites suggestions - every single one. I am now not sure what to do, the game is pretty much unplayable.

NVIDIA GeForce GT 330M:

Chipset Model: NVIDIA GeForce GT 330M
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0a29
Revision ID: 0x00a2
ROM Revision: 3560
gMux Version: 1.9.21

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro6,2
Processor Name: Intel Core i7
Processor Speed: 2.66 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Memory: 4 GB
Processor Interconnect Speed: 4.8 GT/s
Boot ROM Version: MBP61.0057.B0F
SMC Version (system): 1.58f15
Sudden Motion Sensor:
State: Enabled
This is more or less identical to me, I have similar Specs and experience. I would only add that the game never ran 'wonderfully', rather it's just abysmal in its current state and certainly a downgrade performance wise.
Even shopping the AH right now is the same, where you mouse over something and it takes a while to register... pretty bad...

Join the Conversation

Return to Forum