"Mighty Blow" achievement not awarded.

Bug Report
After killing 30 or more enemies with a single blow, I don't get the "Mighty Blow" achievement. I've killed exactly 30 (cf. http://i.imgur.com/7Cvwn.jpg ) and more than 30 enemies (up to 42-ish) with one blow multiple times, on Normal difficulty, and haven't gotten it.

All attempts were made in a solo game using my mid-40s level Monk and the Wave of Light skill with the Explosive Light rune in Act II during the Lord of Lies quest. The location is in the Desolate Sands, near the northern spawn point of the Ancient Device, i.e., just below the bridge which leads to the Archives of Zoltun Kulle.
BUMP. Same problem here. Tried with a barb, broke 30 multiple times (even as high as 50).
Tried vs Iskatu in A4, as well as in in the arreat crater and in the core of arreat.

EDIT: Tried with DH, rain of vengeance, fan of knives, rapid fire. All reach over 30 units killed.. all fail to trigger the achievement.
Same, I've done as far as 37 with one attack multiple times now,still haven't gotten it. gotta be more recent to as my other account I got it within the first 2 weeks of game launch.

Join the Conversation

Return to Forum