Failed to start streaming download??

Technical Support
Is the server down or something? Unable to connect stuck up at initializing...
Any1 having the same problem? restart the modem & comp still unable to connect...
yaa me too.... n i think its the server... :(
Same deal with me. Was working fine 2 days ago, with the 1.0.6 download. Now login screen shows 1.0.5 and tells me it will shut down and download patch, but, nothing happens ???
Same problem here. For almost a week now, I've kept getting the "Failed to download streaming. Please check your internet connection and try again" error message. Everything was working fine before and I have not installed any new programmes on my computer or configured my router/internet.

Omrakos - thanks, I've tried the steps in your suggested articles but the problem still exists.
I've been experiencing the same problem for a couple of days now. I've been looking up for solutions around the net but none seem to work.

Omrakos - your suggestion worked the first time and I was able to play for a while. But when I launched the application, the same problem occured.

Is the problem because of our connection? or is there something wrong with the server itself?
Hello. I have the same issue.
I tried the 2 things from Omrakos.
I also tried downloading the patch manually and changing the files and I still get stuck on initializing or on 0.0%. In all scenarios, if i click on the Info menu, and than Connection Information, there is no download. In this last attempt - as i am writing this post - there is just no data transfer but there is a download initiated. just no... download action. and that's with the new patch files manually installed.
I tried ... running as Administrator... insae it would change anything... obviously it didnt but atleast i tried something else.

Ive been having this issue since the new patch, for up to 2-3 day-ish?

Oh. update! as im writting this im at 32% but it stopped... also Id already have the patch files...... I was pretty sure manually installing the patch would be pointless but now Im sure.

2 minutes later. 51.6%

3 minutes later. 98.1%

Ive noticed it goes with total lack of action than a big update on the eta.

update; replaced the new dowloaned "patched files" with my old files to be safe before logging in (i closed the game before changing files. obviously)

O SWEET! now it says theres a new patch available. but when it restarts the launcher. the game is up to date already. great... im not going to put this in the other thread with the same issue though since its probably linked.
I have the same problem, running W8, tried the advice in both links, no good! Help Please
"Failed to start the streaming download. Please check your internet connection and try again."

The launcher just says this and then closes. It's been a few days now.
I had this problem few days back. It just happened suddenly.
I had to uninstall and reinstall the game to get it to work again.

BUT, just 2 days later, it happened again! Was fine one moment, 2 hours later, launcher was stuck at initializing. Then the message "Failed to start the streaming download. Please check your internet connection and try again."

Please advice. Can't keep deleting and re-installing the game every few days...
I was having similar issues until I stumbled onto this solution.

http://patchup.info/d3/tfil/
The same problem still exists...can Blizzard please provide technical support??? It has been over a week now and is rather ridiculous...

Join the Conversation

Return to Forum