Error 14404

Technical Support
1 2 3 7 Next
Has anyone ever encountered this one? It says error with the authentication module.

Any ideas on what I can do? It's keeping me from being able to log in...

Managed to log in but has happened to me a couple of times today
same here. i tried to log in just nowand im getting the same error.
I am having the same issue .... I am on a mac, just dled the game, havent gotten into it before. Any help would be appreciated.
I too am on a Mac and can't seem to log on. Could really use some answers
me too
So do I, error 14404 !
i tried to download PTR (PVP) but suddenly my pc restart..and when i logged in...ive got error 14404.....help
..
what do u mean?
same with me. help
Yeah im getting error now as well just downloaded the game again after a format
same too. plz help me.
I encountered this too and solved. Not sure could help you guys. I am in Asia but playing at American server. I encountered Error 14404 after entering my authentication code. I then changed the option to Asia server, it now could prompt me to accept 2 agreements and could logon success. I logout and changed back to American Server, it then could logon successfully. Hope this helps.
Same steps as Homaki pointed out. Just change to other server, accept whatever prompts pops up, click back or log out then revert to your original server whatever that is - should be able to log in by now.

Solved mine, no prompts encountered.
Homaki,
great advice for people in Asia and playing on American Server with this problem.

LIKE! or +1 , or whatever . :)
I just already login 1st change the Option in region then login after the screen create appear then back and change sa option in region to American then login success..Wish could help others with this kind of problem.
I am getting this error code as well anybody have any luck with a solution?
so already 1 and half month, no staff from blizzard ever reply this topic? i am getting this error also

NVM i FIXED BY MY OWN SELF! just changed the regional login to other server clicked accept of the stupid aggrement button and switch back is ok.
changing server worked for me!

Join the Conversation

Return to Forum