Updating Blizzard Launcher all the time

Technical Support
Recently, when I start the game from the launcher, I always get the "Updating Blizzard Launcher" message and the launcher seems to update. I wait for it to finish, then I start the game normally and play. No errors whatsoever.

However, I seem to always need to update every time I launch the game. This started last patch day. Anyone else experiencing/experienced this? I tried searching for a solution here, one mentioning to delete the MPQ files on the 'Updates' folder, but it didn't work. :(

Try deleting the Diablo III\Diablo III.mfil file, then running the game again. If it continues to update and actually seems to be doing an update, not just bringing up the Checking Updates screen, run the game as an administrator. To do that, right click the desktop icon for the game and select that option from the drop down choices.
Tried both. Neither worked.
i also has this same problem. cant seem to work too.
any other solutions, waiting 20 minutes everytime to start the game is getting annoying.
I have been having this same issue since I rebuilt my computer. Reinstalled D3 & its still happening. Trying the suggestions here brought no change. The copy on the girlfriends computer works fine. Maybe 1.0.7 will fix it.

Join the Conversation

Return to Forum