Can't add/remove authenticators

Technical Support
I am having a strange issue. For some reason I can not add a mobile phone authenticator or remove my telephone in authenticator.

I called the number and hit all the numbers to remove the phone in authenticator. It said processing and I should call back if I wanted to add it back. So I thought it worked but when I verify the phone authenticator has been removed it fails.

Also when I try to add a mobile phone authenticator it says my email has to be validated which is fine, except it fails to send the email and if I hit retry it just fails every time.

I tried changing my email in the system but it still always tries to send it to my username email which is valid and I use everyday.

All I want to do is remove my phone authenticator and add my mobile phone. I understand that the security page has to be secure but mother of god it should also work.

There is something wrong with my account as the phone authenticator will not remove. I have tried a couple of times over the last weeks and it will not remove.
BrianDavid ,

This isn't anything we can help with here in the Technical Support forum. I suggest calling in and speaking to a Billing representative.

Billing representatives are on hand to take your call between 10am to 6pm Pacific Time, 7 days a week at 1-800-59-BLIZZARD (1-800-592-5499). Customers in Australia should call 1-800-041-378.

Join the Conversation

Return to Forum