Unable to set diablo3 past 1920 wide

Technical Support
Sunako ,

I really don't know then, it's got me stumped. All you haven't swapped is the video card itself but I don't see how it could be the cause with just one game. I guess I'd have to suggest reinstalling at this stage.


You have other systems it sounds like? Do they have Diablo III running at the higher res on their 27" screens? If so, you might be able to just copy their game folders over rather than reinstalling.
none of the other system have diablo3 on them but tried running diablo3 of the other off a copied version from this machine and has the same issue. im about to reinstall diablo3. will update as soon as i have it patched.

It's looking like it has to be the game being corrupted somewhere then and not hardware at all since you now have 2 machines exhibiting the issue. I leave in a few minutes for the day so I won't be able to post any more until tomorrow but reinstalling is looking like it should fix it now.
ahh but it almost finished downloading.
After reinstall it still happens. on both machines fresh download on each one no coping of files.

Strange thing i noticed after restart is that diablo3 installed to the correct directory but no quick start icor and no start menu folder were created. going to uninstall and redownload once again.

Looks like the installer I had was corrupt got a newer version of it and got a completly different install prompt.

Crossing fingers that this one works.

Reinstall 2 and 3 both came with the same results. Starting on #4 with a new SSD in this machine. new firmware and OS.
Giving up for the night didn't work with new SSD with seperate OS, didn't work with display port 1.2 and didn't work with HDMI 1.4... No luck with any under or over clocked refresh rate at 2560x1440. DID work when connected to friend macbook pro for all 3 2560x1440 displays.
Did not work when connected to a friends ViewSonic VP2290b ( i know its not a monitor for gaming but was only other monitor over 1920 wide). Angers me because i don"t have any more 1080p screens that are under 40". will test its i can get it to work across eyefinity some time tomorrow.
OMG so i hate this so much AH , achie, Character Profile, and any thing rendered on or withing a UI window is fine only the map textures are messed up as far as i can tell. went into the game with it messed up can target and highlight mobs and npc's along with some interactible objects.
If you run out of options or need a fresh set of eyes and minds for your issue, try asking around the Widescreen Gaming forum. There are lots of very knowledgeable people there that may be able to provide some tips. http://www.wsgf.org/forums
hey Sunako.

this is a stab in the dark but, are you using Fullscreen or Fullscreen Windowed???

because i know if i have the game in a lower res than monitor and hit fullscreen windowed, i get the same symptoms you are describing, i usually have to go fullscreen once then back to fullscreen windowed.
Have tested it in windowed full screen and windowed fullscreen with no change when i put a AMD 7970 in the machine today to try eyefinity it didnt change either. I can change any of the monitors to portrait mode and make the window taller then 1920 but still cant go any wider then
1920 i will be home from work in 45 mins thur and hour to do more testing.
AT home now tried switching in the order Maazer said with no luck
New problem just happened for the first time before the reinstall of diablo3 i was able to have wow and D3 open at the same time. if i switch between the windows now i get a error for the first time. reading " graphix Error" "An error occurred resetting D3D." "Click OK to retry".
Still no luck after 8 reinstalls now. (>;o:<).

From everything you've done, I think it must be a Windows setting you're using on all machines when testing or another app running on all of them. Are you able to run any of them with a clean install of Windows with nothing added except Windows updates, Service Pack 1, and the game?

Whenever I come across this error from a user, it's usually due to them running the game at a res their monitor can't handle. It often happens when they use an HDTV. The solution to get them going again is to force the game into windowed mode so they can get back to the menu to change things.

Cabling can do it too. In the case of your monitor, I asked early on about how it was connected as articles I found for it on the net indicated it had a limit of 1920 when not using DVI. (ie. display port/hdmi) It seemed like it might be more than a coincidence at the time.
the only changes made to the windows image on the second SSD with windows 7 64 on it are disabled aero , disabled indexing. i was able to get a windowed mode to show as 2560 wide on the desktop but the background resolution in the window was not matching the window width.
I brought a dell ultra sharp U2711 home from a friends today with the same effect. i even used cable from him that is confirmed to work for him in diablo 3 at 2560x1440.
thank you for all you help just randomly fixed it after running driver sweeper across all of the machines. looks like the base driver on my image drive seems to have had an old 200 series driver. that part of it must have not been getting removed. But not sure why it happened whn i tried the ADM 7950. going to test it in a few mins to see it it still happens there.
New issue when in fullscreen mode when alt tabbing too any other window or desktop diablo3 always stays on top.
Also the Helm shield and monitor symbols for profile achiev and game options are now out of place by about 1/2"
Sunako ,

Whoa! You're throwing too many issues at me at once :)

So you're saying you fixed the problem we've been working on by running a driver sweeper across all machines?
all the machines are working now. but cant match the viewsonic to native. but that not an issue its a 50ms monitor and not ment for gaming.

Join the Conversation

Return to Forum