1.0.6a and Error 3007?

General Discussion
Prev 1 23 24 25
Also in Japan with the same problem. How did blizzard single handedly break the internet? This seems like a serious security issue.
Thank you for the help, but it didnt work. I guess I have to wait for my ISP to update.
12/15/2012 02:15 AMPosted by PHM
Change your DNS to or and it will surly work. It worked for me.

thanks this worked for me
This didn't work for me.
how do you change to google dns pls? I'm an old lady with little computer knowledge Have Windows 8
I am using windows xp and there is no network sharing. please help!
Which Telecommunications company has control over routing in Singapore, New Zealand and Australia? None off the top of my head.

Now if they all the traffic was routing through one country I could buy that. The problem is each of these three countries have alternative means of routing and/or more direct and effective paths for the networking to get routed to them.

The only other possibility would be an issue with something on the receiving side (most of which is around California) where a majority of the international traffic is received from the SEA region. However the ISP's would have different wholesale agreements with different international carriers.

And it seems very unlikely that several ISP's would develop the exact same issue simultaneously as their DNS address would each vary. [/edit]

As much as I would love to believe the story I can't see a logical reason to believe it. Also changing my DNS did not provide relief even after flushing the DNS.

Sad panda.
I have paid REAL money for this game,some times I have a bit of time to play it. These days I spend my time waiting just to get an error message (14404)!! I feel it is very unfair to be treated as if I had stolen this thing!!! Many problems,rare concrete solutions and never any compensations for time lost and wasted on poor workmanship or incompetence BRAVO!!! We have nothing better to do!! Thanks!! It's really worth the price we paid!!!
I am still running into this issue today :/ i changed my dns about a month ago and now its doing it again? so frustrating...
I've had an entire month of not being able to play Diab3. wtf is with Blizzard that their patch stuffs up so badly?
The "workarounds" on two different threads have not resolved this issue.

Is there not a single developer in the entire Blizzard company who raised the issue about actually testing a patch before releasing?

I paid the extra premium price for a damn global version direct from battle net.

Ok, so patches break sh-t, and bugs arise. But as a paying client I expect the turn-around time for a fix on a patch-induced bug to be a maximum of a few days, not a ****ing month.
Oh sorry, my bad, I completely forgot that Blizzard had shifted their resources to rushing out that other cash-cow expansion, Heart of the Sh** or something.

That must explain why this issue hasn't been addressed.

Dare I say there won't be a single bug somewhere in THAT glorified map pack.
Error 14404 on 12/02/13.
Tried all workarounds, able to connect and accept the agreements on both the EU and Asia servers, still unable to connect to the Americas.
Disabled IPv6, no difference.
Enabled IPv6, no difference.
Called up Optus, had them change a few things, no difference.
Waiting 24 hours before I call up Blizzard to complain.
Though I imagine they'll just ask me to call back Optus, and the cycle shall continue.

Really don't want to play on the EU or Asia server, as my characters are on the American server.
I know I'm making the choice not to play on the EU or Asia, but I paid to play on the Americas with my friends.
Somewhat disappointing..

Join the Conversation

Return to Forum