[workaround] Disconnect w/ VSync for WW Barb

Technical Support
like many of you I play a WW Barb, and for a long time I was suffering from the Client Disconnect error.

I searched and tried everything on the forum on the internet.
Nothing worked.

However, some people did fix the problem by diabling VSync in the Game Option.

I tried that and did not work. And, it makes the gameplay look very bad.
So, after some testing and try different things.
The problem seems to related to the FPS setting.

I finally come up the workaround with VSync on and no more DCing.

1. Turn off VSync
2. Low the Max Foreground FPS to below 150 default.
3. Play the game and have GPU monitors on a different screen
4. Keep eyes on how bad the new FPS stress your GPU[s]
5. Low the Max Foreground FPS to low enough that GPU[s] are not over 75% load.
6. Turn on VSync in the Display card setting instead of inside Diablo 3 Game Setting.

Worked out for me beautifully. no more DCing and no more screen tearing =D
i have been a happy WW Barb for a week or 2 since those change of settings.

My guesses on this problem is that the frame dump are too much for the FPS setting against the VSync settings.
Or, probably the number of frame dump triggered some error condition, or blocked the network thread whasotever it timed out and raised DC error prompt.

Hope this helps out!!
Good luck on loots!!!


Join the Conversation

Return to Forum