Password reset link not working Update

Technical Support
Hi Blizz...this is to inform the team that I have seen a couple instances of this and the fix was to change the SEA to US in the password reset link being sent to account users that have had accounts locked and require a password reset (example:https://sea.battle.net/account/support/password-reset ----- change it to https://US.battle.net/account/support/password-reset). I think this is happening mainly to SEA account holders. Hope this gets fixed soon
I'd just like to confirm that this actually works. My friend has been pulling his hair out for a couple days trying (and failing) to verify his account. We tried it from my place by changing the SEA in the URL to US and it verified perfectly and he can login. At least he can here, fingers crossed that when he goes home and tries loggin in there it doesn't screw up again.

edit: And just confirming - we're in Australia.
This is sorcery. Worked well for me. You have my thanks!
Glad to be of help :) this was really frustrating for me as well...hopefully this gets fixed soon :)
Thank you so very very very much for helping out in this problem.

Been bloody pulling out my hair after so many attempts at password resetting.

Hope Blizz resolves this soon.

Many thanks! And hv a merry xmas.
You are ma savior.
Add to that, battle net website has a lot of errors other then that. I can't even open feed back and error report ( which I clicked to report this issue ).
Thank you very much.
My password reset link still doesn't work. SOMEONE PLEASE HELP!
You're amazing, you are. Just when I thought all hope was lost I come across this. Thank you.
To any Blizzard employee reading this, you should really put this in the FAQ page under Unlock Account section... until you can fix this issue for us SEA users, that is. I believe this will help reduce some of the workload for your Contact Support team as well. Thank you.
Omg thank you so much i have been having this problem for a couple days anyway ty so much :)
thx man, its work. thx so much. love u.
thankx man... its just as simple as that... and blizzard dont fix it and wasting our time...
good job
Thank you!!! been very irritated by this!!
As usual what works for others doesn't work for me. :(

Join the Conversation

Return to Forum