Error 37 and 73 Authenticating service.

Technical Support
Couldn't resume a game, Couldn't leave party. So I tried to log out and back in to see if it'd fix it. Getting this now.

Or something like that anyway.

Edit: Getting 73 now. Bnet temp service outage.

sadface.
same here cannot log in couldn't resume party
Getting the same error.
just keep trying...a lot of people got kicked off the server and everyone is trying to login...took me 3-4 trys to get in
Yeah, I can't log in.
People on WoW just got booted too and RealID friends list went down..something is likely up with Bnet right now. Showing up on both forums. Give it a few and I am sure they will get it restarted :)
Thanks Cheetah. Good to know.
Both error 3006 and auth server too busy (37) coming up for me. Will try again in a few hours. :-)
same lame bug..........
I got error 73 too :( I'm just a harmless noob! Let me play blizzard! :P
same errors
Same here, Error 3003
The authenticator has !@#$ed me more times than helped with anything.
I'm not getting an error message, but I got kicked out mid-fight and now my game is getting stuck on the authentication process.
I'm having the same problem, all server status are green though.
I take it back, it got finally went through to give me the 3003 error. Fail. The worst part is, I was farming a location spawn, it finally showed up, and it crashed right before I got inside.
73 Error here - 2 times before I cam here.
I'm getting the same 73 error. I was looking at some older threads with a blue post about 73 and he replied with -

"I don't believe I've ever seen an error 73? Are you sure that's the code you're getting? At what point during the login process do you get it?"

"Edit - looks like a 73 can happen if the severs are temporarily busy, have you tried again?"
Just to mention, I tried to log into WoW and didn't have any problems. It's only Diablo 3.
Yet Another Blizzard Non-Entertainment Moment......

Join the Conversation

Return to Forum