Lag issues while playing Diablo III

Technical Support
Hello, recently I purchased a new laptop to replace my older less reliable one. This laptop's gaming abilities is far superior to my last.

However even with that, I still seem to be experiencing issues when trying to play this game. I have not so much lagging, though it certainly feels like that, but more of a "jumping" issue. It is particularly bad when monsters appears on the screen. I don't believe its lag simply because my latency is always in the green floating around 101-102 most of the time. Also as I said the jumping/lagging whatever I should call this only really begins when monsters come onto the screen.

I have turned all graphical components in the game to the lowest settings and I'm still experiencing this issue.
My last computer, though far worse at handling gaming played nearly the same at all the lowest settings. I figured with a better computer I should be able to play the game more smoothly, and at higher settings but so far this hasn't been the case.

I honestly don't know much about computers, and I bought this computer while it was on sale (the newer model was out). So this computer, when I bought it, was over a year old so I'm not sure if everything is fully updated to where it should be.

Just wondering if anyone could possibly help me figure out how to make this game run more smoothly, I am eager to play it.

EDIT: posted before I could put the specs on, pressed the wrong button

Processor: Intel(R) Core(TM) i7-2670QM CPU @ 2.20GHz, 2201 Mhz

Windows 7 Home Premium

64-bit Operating System


Graphics: NVIDIA GeForce GTX 560M

I can add more if needed.

Join the Conversation

Return to Forum