Stuck on Launcher

Technical Support
My game gets stuck on the "Updating Blizzard Launcher" every time I attempt to start the game. It's been like that for a couple weeks now. Status bar goes about 2/3 of the way to completion but just hangs there. Anyone else have this problem or know a solutions? Running XP SP3.
Melonhead

What security programs do you have installed?
______________________________________________________
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
Charter's F-Secure. Think it could be blocking it? I haven't been getting any popups about it, but I'll see if I can figure something out.
i have the same problem, im using W7 home premium, McAfee Security center.
When i run as administrator it goes only 1/3 of the bar
I tried turning off the firewall after deleting the Battle.net folder like some other posters in different threads have suggested, but I still get hung on the Launcher. Sucky.
Figured it out, finally. F-Secure has an option to "Do not allow applications to download harmful files" even when the firewall is off that was activated, and it must not have liked Diablo 3. All is well now.

Join the Conversation

Return to Forum