Error "Failed download info about next patch"

Technical Support
I can't log in.

Basically, I clicked on my d3 desktop icon to run the game, launcher pops up and updates to 100%, but then all of a sudden it just closed. When I clicked the icon again, everything seems like it's going normal, except I then get a pop-up message saying this:

"Failed to download information about the next patch. Check your network connection". When I click the "ok" button to dismiss this error message, the launcher screen which usually allows me to press the "play" button just closes.

My network connection is fine. What is the problem? Why can't I log in?
Still doesn't work.

I followed both articles and deleted the "Blizzard Entertainment" and "" folders. Note that there was a "Blizzard" folder which I did not delete or touch.

Upon deleting the two folders, I tried running the d3 again. Launcher was going, and then I get this error message:

"We could not connect to the patch service. Please your internet connection and try again. Please click the link below for more information or contact customer support if problem persists. Error code: BLZPTS00002"

Try deleting the Updates folder inside the Diablo III folder along with the Diablo III.mfil and Diablo III.tfil files. Then delete the C:\ProgramData\ folder again and try the game again afterwards.
I Found the solution

FIrst : Install Regkey-removal ( I used [removed]) scan for reg files and remove them

Then Install :) So simple and so hard till you figure it out :)
Tdot ,

I don't recommend downloading and running ANY software that's going to delete registry entries unless you know for sure what that software is and how it works. That's an easy way to get malware or a keylogger installed.
well I had the same problem for 4 days and This is the only way I believe that once you download the new patch you get some sort of corrupt reg-key file and until you remove it you can't run the d3 program I'm currently Installing it so it worked for me
Omrakos, your solution worked! Thank you! Maybe you want to try this Tdot if it happens again to you in the future?
well :D I didnt know what to do so I deleted my agent and after that I keep getting the same error that's it didnt worked for me I tried his way but nothing :D:D It's alternative
This is a problem with Blizz. We all had this problem after Blizz updated their launcher. And instead of figuring out what the real problem is, they added 2 links which proved utterly useless.

I dun expect blues to assist cos frankly they are just the messager boys. Who have 0 IT knowledge, they should all just go back to preschool!
had the same problem i simply started the download by running it as administrator worked just fine ....

Join the Conversation

Return to Forum