This is frustrating Blizzard.

General Discussion
Ok I paid 80 something Australian dollars to buy Starcraft 2, and it wouldn't let me play, keeps saying "I need an authentication module". I tried reinstalling the game numerous times and nothing happened, and it took me like an hour if not two to install the game to know that I can't play again.

And I bought this Diablo 3 yesterday, which I thought it's a different game. And BOOM, the same thing happened again after I spent like 2 hours to "simply wait for the game to be installed". After 2 hours of tedicious and time-consuming wait, I learnt that I can't play the game less than a second when it says the same thing again "authentication module".

I don't want to be rude but this is simply frustrating and irritating. I don't know why I spent so much money to buy the games I want and simply ending up not being able to play, not to mention all that time I have wasted just trying to reinstall the game to solve the problem. I want my money and time back.
bad forum and in ur account support u can find authentificator problem or somthing like that.
Got a smartphone? Tried attaching a authenticator to your account yet?
don't you have to tweek settings with authentication to allow you to play the games?
Blizzard has your money. Why would they fix anything to help you?
Follow instructions in the thread linked below to change your DNS and I'll guarantee it will work. We shouldnt have to do this, but this will bypass the issue.

Join the Conversation

Return to Forum