patch 1.0.7 problem

Technical Support
hi,

D3 did patch but after the patch i want to play and its says D3 need to patch and it closes the game for a restart but game is up to date so what now ?
I have the same problem here
and i don't know what to do ?

Please help
Same here, what's up?

Join the Conversation

Return to Forum