Very poor FPS on late 2009 iMac

Mac Technical Support

I have a late 2009 iMac. Here are some specs:

system: 10.7.5

Processor Name: Intel Core 2 Duo
Processor Speed: 2.93 GHz
Memory: 4 GB

Graphics card:
Chipset Model: NVIDIA GeForce GT 120
VRAM (Total): 256 MB

Problem: I'm suffering from very poor performance/low FPS. My settings are set to low and I usually play in 1240x786.

The thing is that I can play mostly fine in Act1&2 where framerate is very good. Act3 is the problem. Also, it gets better the 'longer' I play i.e. the framerate is very poor for the first 2-5 mins or so but then it gets fine (but sometimes i does not).

I tried lowering the resolution a bit but it didn't really change anything.

Is there some optimization I could do or should I come to terms that this Mac is outdated?
When you state it gets better the longer you play, is it like stuttering during the first few moments of the game till it fixes itself?

What FPS are you seeing when you have performance issues vs when it is fine?
I have roughly the same MacBook pro early 2009. The stuttering in the game got so bad I had to stop playing. It's in unplayable.
I will be fine in town, but can feel a hint of stuttering, once I go into battle area I feel it more and once I encounter mobs forget it. It stutters so bad u can count up to 5 sec before the next animation happens. This happens when I play public or close rooms with friends
It was fine up until the ptr and all the auction house updates.
I did most of what I can do from your solutions for macs and still the same.
Please help.
Hey Plissken,

I've had the same issues you're talking about since the game released. I tried everything just to be able to play the game – adjusting framerates, low settings, windowed mode, adjusting my default monitor resolution, reseting PRAM, reinstalling the game, etc.

There were constant framerate drops. Every time I moused over items or doorways, the framerate would drop. There was always a huge drop whenever something exploded or had fire effects. Even when the game was running decently, there was a constant mico-stuttering. I played the game with everything turned off and the resolution at 800x600, and the game still didn't run smoothly.

The good news is: I've had some really good results playing the game lately. Here is the rundown:

My specs:
27-inch, Late 2009
3.06 GHz Intel Core 2 Duo
8 GB 1067 MHz DDR3
ATI Radeon HD 4670 256 MB
OS X 10.8.3 (12D78)

I want to provide my D3Prefs.txt information because I think this is what truly helped my gameplay experience.

The really important items to pay attention to are: DisableTrilinearFiltering and HardwareClass. Other than that, make sure all of your settings are on low and your resolution is set to default or a setting higher. Reducing the resolution to the lowest setting actually causes the game to play less smoothly because it can't quite handle the full 60FPS (assuming you have Vsync enabled). The game tries to animate somewhere between 30 and 60FPS which causes stuttering.

You can also turn off anti-aliasing if you're still noticing framerate drops, but I found it held a steady 30 FPS on these settings:

PreferencesVersion "44"
PlayedCutscene0 "15"
PlayedCutscene1 "15"
PlayedCutscene2 "23"
PlayedCutscene3 "143"
DisplayModeFlags "12"
DisplayModeWindowMode "0"
DisplayModeWinLeft "530"
DisplayModeWinTop "302"
DisplayModeWinWidth "1520"
DisplayModeWinHeight "820"
DisplayModeUIOptWidth "1530"
DisplayModeUIOptHeight "860"
DisplayModeWidth "1530"
DisplayModeHeight "860"
DisplayModeRefreshRate "60"
DisplayModeBitDepth "32"
Gamma "0.810000"
MipOffset "1"
ShadowQuality "1"
PhysicsQuality "0"
ClutterQuality "1"
Vsync "1"
Letterbox "0"
Antialiasing "1"
LowFX "1"
LimitForegroundFPS "1"
MaxForegroundFPS "30"
LimitBackgroundFPS "1"
MaxBackgroundFPS "8"
DisableTrilinearFiltering "1"
ColorCorrection "1"
MipBias "0.000000"
ReflectionQuality "0"
TonemapExposure "1.900000"
TonemapContrast "1.500000"
TonemapSaturation "1.000000"
TonemapGain "1.000000"
HardwareClass "1"
PCIVendor "4098"
PCIDevice "38024"
MasterVolume "1.000000"
EffectVolume "0.800000"
MusicVolume "0.800000"
NarrationVolume "0.800000"
AmbientVolume "0.800000"
ChannelsToUse "64"
SoundDriver "0"
SpeakerMode "0"
ReverseSpeakers "0"
QuestSubtitlesEnabled "0"
CinematicsSubtitlesEnabled "0"
MuteSound "0"
MuteEffects "0"
MuteAmbient "0"
MuteVoice "0"
MuteMusic "0"
Hotfuzz, your machine is different from the OP's and is likely a different issue. Could you please start a new thread and make sure to put in as much detail about the problem as you can? Thanks/ :)

Join the Conversation

Return to Forum