Lag issues post patch

Technical Support
I have been lagging for the past 2 days since the patch come out.

I have a really good gaming computer and a good internet connection and speed at 30 - 50 mbps. I never had lag issues in the past, save for, launch month back in May 2012! But now, i am lagging as if its 300+ ping and strangely the FPS shows 50! (which is not the case)

Blizzard any update on this?
Ive posted on this issue as well as many others. Something is cleary wrong and hopefully they are in the process of working on it.
Same for me. My ping fluctuates, and is normally smooth even with everything on. Annoying, can't enjoy the new patch. Please fix.
Blizzard! Please fix this! This lagging really affects our gameplay!!!!
Same here.. Very lag and skills are very delayed.. please.. need your support here. :((
Please fix that lag issue !
Big lag problems for me aswell, wow is fine d3 is unplayable.
I'm having issues as well with this... please fix this problem
i dunno if its my internet or what (i cycle between a few neighbors wifi's - the signal strength isnt always the best), but i've been lagging more the past 2-3 days as well.
This always happens to me when a new patch comes out. People return to give the game a chance but since Blizzard clearly doesn't have the servers to support this load, some of us lag constantly. What ticks me off is that I'm not one of those band wagon jumpers that come back on cause there's a new patch. Seriously, just stop patching the game altogether, I'm sick of having to lag every time a patch comes out just to have to wait 2-3 weeks until you guys fix the issue.

I mean seriously, what kind of company lets the same problem plaque them over and over? So sick of this crap. So glad I returned to this game a month ago just to have and deal with the same problems I did when I quit 5 months ago.
I've been having this lag issue for the past 2 days. Blizzard is loosing our trust. They don't know how to take care of its clientele. I'm not shock about this issue thou; they got our $60 for the game and now we are left to our own luck. Shame on you!!!!
I've also been having this problem I just want to hear something from blizzard that there working on it, or at least acknowledge they're aware of the situation.
My favorite part of this game is when you're fighting 2 elite packs and working them down and then you begin swinging at air and the monster stop moving. That's when you know you're about to get 1 shot by the group.
It's probably safe to say everyone's having this problem. I tweaked the crap out of my router and ran through everything on my end and my ISPs end before I checked here. Glad to know it's not just me.

They really need to fix this, the game is unplayable as is. You're fine for awhile and then stutter stutter freeze... come back dead, throw out some profanities, repeat. Was doing just fine before the patch :/
Same issue here, something in Diablo 1.0.7 is causing ping rates to spike every 10-15 secs once you start battling. I even trying pinging other sites such as and diablo client is causing issues. Tried it on two different computers win7 64bit and win8 64bit. I can play other games with no ping spikes.
Unbelievable! What can be the solution here? Blizzard is not even taking action yet.
I'm having lag since the patch too.
02/16/2013 07:19 AMPosted by Gerwe
I've also been having this problem I just want to hear something from blizzard that there working on it, or at least acknowledge they're aware of the situation.

Will never happen

They don't care D3 is the only game you're lagging with, they don't care your ping to any other website remains good and stable while your game experience is completely ruined.

They never did. At best, a tech will ask you for a traceroute and find the one hop among 30 or so that is not perfectly fine (London Cogent in my case) and blame it on your connection...
I also am having the lag problem since the latest patch update. I originally posted in the bug report forum and was redirected here.

This is my post in the bug report forum from 3 days ago.

"I am experiencing a serious lag and stalling in gameplay since the latest patch update went live. I cannot get anywhere now as my all of characters stall and then immediately die when the game jumps forward from the lag/stall. This is not a connection problem as it has not happened before now; and has happened every single time I have signed on and tried to play since the 1.07 patch update; regardless of which character I use, day of the week played; or even time of day"

And from what I have seen, not only does the problem continue, Blizzard has not even bother to acknowledge it nor anyone
One thing this BS has taught me is to never buy a game that requires an online connection for single player. I will freaking quit gaming if every company goes this route. It's total BS.

It's like buying a car that only runs when it feels like it and not having any recourse. In what reality does this business model work?

Join the Conversation

Return to Forum