Nvidia Drivers 314.07

Technical Support
So I updated my graphics drivers to the latest release from Nvidia (314.07) and started getting some pretty severe micro-stuttering. About every 20 seconds or so I'd get a few stutters and then it would go back to running smooth again.

After reverting back to my previous driver version (306.97) the issue disappeared and Diablo is once again running smoothly. For the sake of reference, I'm playing on a GTX 670.

These drivers were released on 2/18/13, so unless you've updated your drivers this week you probably haven't noticed the issue. Anyone else having this problem?
DeadPan,

Thanks for the info.

So far, reports I've seen indicate the 306.97 release is probably the most stable still. This comes from reading Nvidia's forums primarily as people post about all apps there, not just Blizzard games.

I'm not saying not to use newer drivers as they come out, just that you should be aware of possibly introducing a new issue you didn't have before and be prepared to revert if necessary.
Thanks for quick response Omrakos!

I did some glancing through the Nvidia forums myself and I see what you mean. Lots of reports with stability issues in post 306.97 drivers. People reported similar stuttering in other games such as BF3 and Skyrim. Some people mentioned that the stuttering was related to AA which I can't really confirm since I didn't try disabling AA while running the new drivers, but if people are really determined to use the latest drivers disabling AA might be something to try.

For me, I think I'll just stick with the 306.97 drivers for now. They seem to be running everything great, and I don't really plan on picking up Crysis 3 anytime soon anyways.
I, for one, am still using the 306.97 drivers and since a little bit after the patch (there might have been some hotfixes done b/w now and then) have experienced far more problems with drops in FPS. I had not been experiencing this problem pre-patch and it seemed like the game was running smoothly just after the patch as well, then, all of the sudden the game was practically unplayable. Every time I would run into a pack of monsters it would stutter and then drop to just a few frames.

I'm looking into possible issues with my hard disk. Maybe even doing a reinstall in case I am missing files or there are corrupted files.
I'm having the same micro-stuttering problem with the newest NVIDIA driver update (314.22). I use the GTX 670 as well. It seems as though NVIDIA and/or Blizzard hasn't rectified the problem. The old 306.97 driver runs silky smooth, so I'm back to using that!

I'd love any feedback from someone who knows what's happening....
I'm having the same micro-stuttering problem with the newest NVIDIA driver update (314.22). I use the GTX 670 as well. It seems as though NVIDIA and/or Blizzard hasn't rectified the problem. The old 306.97 driver runs silky smooth, so I'm back to using that!

I'd love any feedback from someone who knows what's happening....

I'm currently using the newest driver on my 660ti, also. I'm going to download the 306.97 driver and see if the game-play is smoother, because I'm also having a lot of stuttering issues with the newest driver.
just tossing this out there. my 560ti works great with 314.22.
most stable drivers ive ever had for a long time.

on that same note... i tried the new 320 series beta drivers. within 5min of installing them the drivers crashed. i wasnt even running anything either just sitting there in windows and they crashed. so... ya those drivers are not goin on my pc yet.
I have tried both sets and still have the same issue creep up time and time again

Join the Conversation

Return to Forum