1.0.7: The game is painful slow

Mac Technical Support
Since I updated the game became terrible slow. Even checking the AH is a difficult task.
I changed my video configuration to the minimum (and I played it on the best on 1.0.6) and the game still is slow. Even if the game is the only software opened.


System Software Overview:

System Version: OS X 10.8.2 (12C60)
Kernel Version: Darwin 12.2.0
Time since boot: 40 minutes


Hardware Overview:

Model Name: iMac
Model Identifier: iMac12,1
Processor Name: Intel Core i5
Processor Speed: 2,5 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 4 GB
Boot ROM Version: IM121.0047.B1F
SMC Version (system): 1.71f21


AMD Radeon HD 6750M:

Chipset Model: AMD Radeon HD 6750M
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: ATI (0x1002)
Device ID: 0x6741
Revision ID: 0x0000
ROM Revision: 113-C2950H-170
EFI Driver Version: 01.00.544
Display Type: LCD
Resolution: 1920 x 1080
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort


Input Source ID: com.apple.keylayout.USInternational-PC
Keyboard Layout: ANSI
Same here. I'm using Retina Macbook Pro. I noticed that my fans won't go over 2000rpm. Usually they go way over that.
Try resetting your SMC to see if it helps.
@Mackhan i tried. The game is a little bit faster now. It's far from perfect, but it's "gameable". I still have to play it on the worst video quality.

Thanks for the answer. I was a little upset for this bug (specially because 1.0.7 is almost 2 week old and there isn't any solution), but I saw a lot of blue answers it this section and I saw that while the Blizzard didn't find any solution, you guys are trying to give us at least a temporary fix.

EDIT: 10 minutes on the game and the problem is back :/
So, are you saying that it starts out good, but then the quality degrades after X time?

What FPS are you seeing when you start off vs when issues start?
Well, I tried now and started with the quest to kill Ghom. The game is slow since on the city. I can walk, but it start slows and suddenly the animation accelerates.

The FPS varies a lot. But now the average is about 8 ~ 10. I'll play a little and have some prints with FPS on.

EDIT: fps corrected after game. And I played a little more.

I played around 15 min and this was my experience:
The selection screen was ok.
When the game started the FPS was 50, but when I first clicked it falls to less than 10. I opened my stash and recorded FPS 7.
When I finally go to fight the FPS was from 7 to 10. It only reach something above 30 with there is nothing on screen aside me or the follower. And even in this case, it lasts not more than few seconds.
On auction house the FPS is about 9, but I have a print with it in 48, but soon it falls again.
I have 16 prints about this very game, including auction house and my configurations.
The prints are here: http://www.sendspace.com/file/z98ye4

Lets see if this helps in anyway:

Rebuild the Diablo III Cache
    1. Navigate to /Applications/Diablo III/Data_D3/PC/MPQs and delete the Cache folder.
    2. Then, navigate to Users/Shared/Battle.net/Agent and delete the Agent.db file.
    3. Run the Diablo III Launcher and let the game update it's files.
    4. Press Play when you see Game is up to date
The FPS improved a little, being 10 the norm. The moments that the fps is high is 60 and lasts a little longer. But still the game very, very slow. Thinking about reinstall it, but since there is a lot of Mac players complaining on the forum, I hope for a kind of patch in a near future
Well, I rebuild the cache as I said on the previous post.
Since it didn't work I stopped to play.

Now I updated my MacOSX to 10.8.3 and I had hopes that it will fix my problem. Didn't work either. It is quite frustrating the state of the game now. An entire month passed since I opened this post and no patch to fix it.

It's almost impossible to play. So, why try it?
I've also noticed the game being much slower than usual. Even at the login screen, I can see the ravens are lagging when they fly. Also, there is about a half second delay when I type or perform any action. I'm rebuilding the cache now, I'll repost when I'm done updating.
Rebuilding the cache didn't work but I reset my PRAM and SMC and now D3 is running fine.

Join the Conversation

Return to Forum