LAG w/ Philippines PLDT ISP after maintenance

Technical Support
1 2 3 5 Next
Blizzard need help. What did you do during the March 19th maintenance? Me and my other friends all over the Philippines with PLDT ISP have the same issues with Diablo 3. Yellow-Red latency always. Streaming videos, playing other online games are smooth but not Diablo 3 after the servers went up.
I too am experiencing this problem (from the Philippines). My ISP is hosted by PLDT as well (indrectly, from Smart Bro, owned by PLDT).
Same here! Lag is so bad I'm dead before I even know it. lol
Blizzard pls check it out, my IP address is 49.144.x.x range. I tried switching to Asian region and there was no problem in the ping 141 ms. The problem lies when playing in my home region - Americas, can't bear the 500ms-2k latency.
03/20/2013 07:35 AMPosted by FreeCredits
Blizzard pls check it out, my IP address is 49.144.x.x range. I tried switching to Asian region and there was no problem in the ping 141 ms. The problem lies when playing in my home region - Americas, can't bear the 500ms-2k latency.


Ok, you are from Philippines and your home region is Americas, but no problem playing on Asian region...

WOW.... I am speechless.

Since when Asean is part of Americas?
03/21/2013 12:01 AMPosted by Veda
Blizzard pls check it out, my IP address is 49.144.x.x range. I tried switching to Asian region and there was no problem in the ping 141 ms. The problem lies when playing in my home region - Americas, can't bear the 500ms-2k latency.


Ok, you are from Philippines and your home region is Americas, but no problem playing on Asian region...

WOW.... I am speechless.

Since when Asean is part of Americas?


Here educate yourself, https://us.battle.net/support/en/article/diablo-iii-auction-house-regional-information
03/21/2013 12:14 AMPosted by FreeCredits


Ok, you are from Philippines and your home region is Americas, but no problem playing on Asian region...

WOW.... I am speechless.

Since when Asean is part of Americas?


Here educate yourself, us.battle.net/support/en/article/diablo-iii-auction-house-regional-information


Why don't you educate yourself first?

There is a difference of "home game region" and "home region".

(Hint: you failed in inserting the word "game")
D



Here educate yourself, us.battle.net/support/en/article/diablo-iii-auction-house-regional-information


Why don't you educate yourself first?

There is a difference of "home game region" and "home region".

(Hint: you failed in inserting the word "game")


You troll you know what I meant. What else are we talking about here in this GAME Diablo 3.
D



Why don't you educate yourself first?

There is a difference of "home game region" and "home region".

(Hint: you failed in inserting the word "game")


You troll you know what I meant. What else are we talking about here in this GAME Diablo 3.


No. I did not troll. His original post really mislead me and I was confused by him.

So, please stop putting words in my mouth. I did not troll.
Clearly you posting in a thread you have no business of, not relating a problem, and taking notice of a simple missing "game" then arguing about it. That's trolling. It's all good though, keep bumping this thread up.
03/21/2013 02:44 AMPosted by FreeCredits
Clearly you posting in a thread you have no business of, not relating a problem, and taking notice of a simple missing "game" then arguing about it. That's trolling. It's all good though, keep bumping this thread up.


I think you are trolling.

I have reported my lag problem too.
Haven't seen your post your problem here. All you did was argue. FYI "home region" is widely accepted in a GAME, search for it and see how many times the word was used. Still trolling I see.
Waiting for a blue response, not replying to trolls anymore period
Same issue here, usually i got 200ms but after the maintenance 350+ latency. PLDT ISP here and
please blizzard help with the random disconnection T_T
Having the same problem too, dunno if it's blizz or isp's fault(PLDT Dsl). No problem in Asia server(getting 190ms), used to have 250 - 290ms latency on US server but now its 250- 1k++ spikes up and down after maintenance. Maybe it's related to this? ---> http://www.sunstar.com.ph/davao/business/2012/12/21/full-restoration-telco-signals-oriental-last-3-months-259417
Im experiencing the same problem... :(
03/21/2013 02:57 AMPosted by FreeCredits
Haven't seen your post your problem here. All you did was argue. FYI "home region" is widely accepted in a GAME, search for it and see how many times the word was used. Still trolling I see.


Yup. I have reported it in other thread.

Yeah, you don't bother about searching it and trying to prove what you prefer to believe.
i dont think it has something to do with ISP.. im using Digitel.. usually at this time i have a descent internet speed.
i agree also that it is not ISP related because the lag spike happened just after the maintenance. When i test my speed it is really okay XD
03/21/2013 12:01 AMPosted by Veda
Blizzard pls check it out, my IP address is 49.144.x.x range. I tried switching to Asian region and there was no problem in the ping 141 ms. The problem lies when playing in my home region - Americas, can't bear the 500ms-2k latency.


Ok, you are from Philippines and your home region is Americas, but no problem playing on Asian region...

WOW.... I am speechless.

Since when Asean is part of Americas?


stop trolling.

the americas is the designated server for most global users in sea/asia.
the ASIA server is literally ONLY for KOREA and TAIWAN.

as such regardless whether it is HOME REGION or HOME GAME REGION, within this context. they are the same. he's from the phillipines, he should not be choosing ASIA server at all. so whatever your point is , is stupid.

Join the Conversation

Return to Forum