issue with mouse skipping or acting "odd"

Technical Support
Since the launch of 1.0.7 I have noticed that the cursor randomly stops responding properly and starts to jitter/skip. I didn't see anyone else posting about this issue so I tried 3 different mice, all logitech being a g500 , mx518, and a revolution 5500. I've updated the logitech software as well as uninstalled it completely and have the same problem. I have also tried different surfaces and still have the issue. This occurs every act though most severely in Act 1 (I have no idea why), single and multiplayer.

Most recently it was happening so often, I decided to quit and realized that as soon as I brought up the in game menu, the issue stopped. I closed the menu and right back to the jitterbug cursor. I normally wouldn't complain about something like this but it makes picking up the items I want in a large drop frustrating and usually end up with an inventory of half white and blue items. This slows me down on public games and I have given up on rares entirely the last few public games I played.

I hope I'm not the only person having this issue as I want it to be addressed. If anyone has any suggestions, please let me know what I can do. Also to Blizzard staff, if there is any information I missed that you feel would be useful, feel free to let me know and I'll do my best to get it for you.
Technical support is probably the place you should post for help like this. Try and search first to see if anyone else had the issue and if a fix was posted. If not then post your own thread. They might be slow to answer on the weekend though.

http://us.battle.net/d3/en/forum/5386227/

Join the Conversation

Return to Forum