Holy hell, these damn disconnects..

Technical Support
Tried my hand on MP10, playing carefully. Get to 5 stacks, took maybe 25 mins. Find the warden, got em down 50%, lost connection...
Ever since this last patch, it's disconnect fest.
I cant wait till some legendary drops and en route, Disconnect.

Can you post some network information?

* Windows Xp, Vista, or 7 (also include if it's a 32 or 64 bit version)
* Firewall (McAfee, Norton, ZoneAlarm, etc.)
* Network Adapter brand, model, driver date, and driver version number (Steps below)

1. Click Start.
2. Click Control Panel.
3. Double-click on the System icon (in Windows XP, you may need to click Switch to Classic 4. View on the left hand side of the screen).
5. Select the Hardware tab.
6. Click on Device Manager
7. Expand the section labeled Network Adapters.
8. Right-click on your network card and select Properties.
9. Click on the "Driver" tab at the top

* Router brand and model # (this should be printed somewhere on the front or back or bottom)
* Cable or DSL Modem brand and model #(this should be printed somewhere on the front or back or bottom)
* ISP (Internet Provider)
* Is the connection wired or wireless
* Location (City, State)
* Traceroute ( http://us.battle.net/support/en/article/performing-a-traceroute )
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
Probably your isp or your modem, server is fine I believe, atleast its running flawlessly for me
You cant play MP10 with that barb! LIAR LIAR LIAR LIAR LIAR LIAR LIAR LIAR LIAR!
1. Win 7 64bit Ultimate Edition
2. Firewall, none. Windows Firewall also disabled.
3. Intel 82579V Gigabit, Driver date 7/20/11, version
I have an Asus P8P67 Pro and these are the latest drivers on their site.
4. Linksys E1000 v1, with custom DD-WRT Firmware.
5. RCA by Thompson, DMC425
6. Time Warner Cable
7. All wired connections, Cat6
8. Brooklyn, NY
9. >
Tracing route to over a maximum of 30 hops

1 1 ms 1 ms 1 ms Glowville []
2 93 ms 25 ms 40 ms cpe-74-64-32-1.nyc.res.rr.com []
3 10 ms 12 ms 12 ms tenge-0-2-0-0-nycmnyr-rtr01.nyc.rr.com []
4 20 ms 15 ms 16 ms bun120.nycmnytg-rtr001.nyc.rr.com []
5 57 ms 14 ms 16 ms bun6-nycmnytg-rtr002.nyc.rr.com []
6 14 ms 15 ms 15 ms ae-4-0.cr0.nyc30.tbone.rr.com []
7 11 ms 14 ms 17 ms
8 33 ms 29 ms 30 ms
9 32 ms 32 ms 48 ms ae1d0.mcr1.nyc-ny.us.xo.net []
10 58 ms 57 ms 40 ms vb1010.rar3.nyc-ny.us.xo.net []
11 39 ms 55 ms 39 ms []
12 13 ms 14 ms 13 ms []
13 85 ms 100 ms 87 ms cr1.n54ny.ip.att.net []
14 107 ms 91 ms 87 ms cr2.cgcil.ip.att.net []
15 86 ms 87 ms 91 ms cr1.cgcil.ip.att.net []
16 100 ms 86 ms 106 ms cr2.dvmco.ip.att.net []
17 104 ms 87 ms 83 ms cr1.slkut.ip.att.net []
18 86 ms 119 ms 82 ms cr2.la2ca.ip.att.net []
19 83 ms 117 ms 83 ms gar29.la2ca.ip.att.net []
20 83 ms 105 ms 83 ms 12-122-254-238.attens.net []
21 89 ms 103 ms 87 ms mdf001c7613r0004-gig-10-1.lax1.attens.net []
22 * * * Request timed out.
23 * * * Request timed out.
24 * * * Request timed out.
25 * * * Request timed out.
26 * * * Request timed out.
27 * * * Request timed out.
28 * * * Request timed out.
29 * * * Request timed out.

If it helps at all, I work desktop support so most of these steps like drivers and windows updates are observered.
Also with my desktop location changed, your dos command output to a dead folder for me.
Of note it worked fine the week before 1.07a I came back. Also when it has happened in multiplayer games, all other players that were in that game, are on my list saying In menus, not in any games.
I started doing crypt of the ancients runs so something as brief as log in, jump into town portal, take 5 steps, will result in me getting disconnected. Since I posted this, I received another one.
Edit: Another disconnect now, 8:32p EDT
Edit2: ANd another, 8:46pm
Also I figure I should mention this. It's not like I time out and stand there spinning around for awhile.
I can be in the middle of active combat, full feedback on the screen, damage numbers, etc.
Then Bam, disconnected. Also this last week since the patch I've been experiencing a bit more rubberbanding as well.
I often have the disconnect occur without the presence of rubberbanding.

1. There is a newer driver available for you network card on the Asus site.

Here's a link where that can be found: http://www.asus.com/Motherboards/P8P67_PRO/#support_Download_30

Once there, you'll want to expand the LAN section and download the first option. There's also a chipset update that you might want to check out, if you haven't already.

***I looked up the P8P67 Pro, not the P8P67-M Pro. If you are using the latter, you'll want to check the Asus site again.***

2. If that doesn't help, can you try connecting directly to your modem to see if that helps at all? If you can, try that. If the connection improves, then you might want to try a new firmware version that is available on the Linksys site for your router. That firmware version was released on 2/7/13.

Here's a link where that can be found: http://support.linksys.com/en-us/support/routers/E1000

You'll want to check under the Downloads section and select your version.
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
1. Yes, that's the version I have. Device manager reports a different number. A lot of drivers are sadly like that in my experience.
Edit : I uninstalled/reinstalled and version # changed to 12.2.45
Still not the stated 17.3 on their site.

2. I'll try a direct connection. I'd really not like to go back to official linksys firmware as I will lose a bunch of features and settings.
I just find it odd it worked fine until this patch.

I'd really not like to go back to official linksys firmware as I will lose a bunch of features and settings.

I understand. I just mention it because I saw someone that was having an issue last week with the same kind of firmware that you are using. They resolved their issue by updating to a newer DD-WRT firmware version, but then again, their router was designed for that type of firmware.

Let me know what happens.
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
Ok, I took some screen shots of settings. Don't think theres dhcp reservations in default, but oh well.
I played about an hour and half, no disc. Did have rubberbanding, then just now, mp4, 5stacks, right outside Azmodan's door, someone in group said anyone lagging? And d3 outright froze with just looping whirlwind sound. Had to ctrl+shift+esc for task manager, which didnt show, then start typing diablo, hit alt+e to end process, spacebar for ok. and that forced it closed and back to desktop.
I reload, check recent players list and everyone that was in that game said In Menus.
And for people that are not tech savvy or not comfortable fiddling around with that stuff what are we supposed to do? , I've been playing fine up until the last 2 patches and now it's pretty much DC every 5 to 10 min even quicker sometimes.
We can try to help walk you through some, but yes, you would be pretty much screwed in general.
What makes it extra odd is that the disconnects are instant. Not the normal performance slowly degrading until you eventually freeze in place and timeout.
This is all, Ding, ahh some gear, Disconnect
So yesterday i turned all of my graphic options to as low as the all could be and Im playing in windowed mode , only had 1 maybe 2 dc's in say 3 or 4 hours of play , so that seems to have helped but it did still happen so the problem is still there.

I got lucky a legy axe dropped and i picked it up and dcd straight away, glad i picked it up
No difference. Just rubberbanding more if anything.
And here's a perfect example.
I get my 5nv stacks, I run around the Fields of Misery, miserable, as this guy loves to be in the last spot you check.
Found em, Wotb up, about to go to town on him, Disconnect.
I guess I didnt want a key, thanks for making the decision for me.

Join the Conversation

Return to Forum