Communication error occurred

Technical Support
Ever since the maintenance on 03/19/13 I have been having problems launching the game. When I got home in the afternoon on the 19th, I lunched the game and it got stuck on the "Updating Blizzard Launcher" for about a minute(normally that message would last about 1 second) then it brought up the launcher and I was able to play fine. I just thought it was a fluke. Then on the 20th when I got home, I launched the game and it pulled up that "Updating Blizzard Launcher" screen again. This time however it just sat there for over 10 minutes before I just decided to end the task. I tried again 4 more times and finally on the 5th attempt it manage to get passed the "Updating Blizzard Launcher" screen(it still took about a minute before It pulled up the launcher which I know is way too long). It is now the 21st and I am no longer able to even get the launcher to come up. It gives me the "a communication error occurred, please restart. If problems persists contact customer support.) I have restarted multiple times and it does not help.

I have the current agent and client. I have spent a couple of hours on the forums trying different "fixes" but to no avail. I thought I would try the Technical Support forums before I just do a clean install of the game. Assistance would be greatly appreciated.
Since I got no response, I uninstalled the game and removed all files associated with blizzard off of my computer. I then tried to re-install diablo 3, I had to run the exe multiple times because the launcher was still giving me problems even though It was a clean install. I finally got the game to install, however it is still stopping on the launcher. It goes about 70% and just sits there. The re-install did absolutely nothing to help the issue. I fear that it maybe be something in registry that changed with the last maintenance on the 19th.
Unfortunately there will not be any blues back until Monday afternoon Pacific time (usually) :(

Have you tried temporarily disabling your firewall and antivirus software? That can cause the issue you speak of. Be sure you are also running from the admin account.
I have done all that and much more. I haven't changed any settings since launch day. The game itself hasn't ever given me any trouble until maintenance on the 19th. The only thing I can think of is that it may be something that changed in the registry. However I wouldn't know what values changed, so I won't be going into that. I just hope that the only way to fix this isn't to reformat my computer.

Join the Conversation

Return to Forum