Stuck on updating blizzard launcher

Technical Support
anybody got a solution yet????
03/31/2013 06:54 PMPosted by Nirvana
anybody got a solution yet????


About the blizzard launcher being stuck? or about the error code?
i tried open IE and press alt+F and uncheck working offline and it worked for me
03/31/2013 08:28 PMPosted by badboyzz89
i tried open IE and press alt+F and uncheck working offline and it worked for me


My IE never goes offline, so that fix doesn't work for me.
I had the same problem..

this worked 4 me.

make a new USER in windows and try play the game in the new user.
I had the same problem..

this worked 4 me.

make a new USER in windows and try play the game in the new user.


I just tried this and it didn't change a thing.
Bumping for solutions. Having the same problem, tried Uninstalling and now it wont let me Re-install.
Check if the windows service "secondary login" is enabled. It should be.

Check if d3 shortcut has shortcut tab / advanced setting "run as administrator" check marked. It should be.
Check if the windows service "secondary login" is enabled. It should be.

Check if d3 shortcut has shortcut tab / advanced setting "run as administrator" check marked. It should be.


Have tried everything that was said on these forums and no dice. I'm pretty sure I have to re-install windows to get this to work right again. It has to be some registry problem.
That's what I'm thinking. ^ I thought restoring to a previous date might do it, but I had no luck.
Bump. Have been trying for hours to play the game with the new patch out. I've tried deleting hidden folders that I've seen in blue posts, disabling firewall, turning secondary login to automatic, nothing has worked.
Hey guys, I ended up De-fragging the hell out of my PC last night. I'm not sure if it was that or the update today that fixed it, but I'm working now. Best of luck to you guys! :)
Well, for those of you who have the current update of the game but are just getting stuck at the D3 launcher I have a temp solution to bypass the launcher and go directly to the game.

edit the shortcut and change

......Diablo III Launcher.exe"
to
......Diablo III.exe" --launch

I found this solution on a very old thread. You can thank kantlivelong for this solution. This will only work until they have a new update for the game, then you will need to go through the launcher to update the game. Hopefully they will solved the launcher problem by then.


I tried this plus running the shortcut as an administrator and it all worked fine.

Thanks a lot man!!
Get rid of this launcher and this wouldn't be a problem.
I have tried all of the mentioned methods and nothing has worked. this has happened to me twice now on an original game.... Its PATHETIC from Blizzard. Last time I uninstalled the game and couldnt reinstall it, left it for a month and finally it insatlled again. The game has been working fine up untill tonight. Im getting fed up with this now. I paid for this product so I expect to use it as i please...

DO SOMETHING BLIZZARD!!!!!!!!!!!!!!!!!!!!!!!!
Hey guys so here is my story.... I had this game (Diablo 3) installed on my desktop. I got a new laptop and decided to install it on the laptop to see if it was any better. Well I put the disc in and started it up and It would show "updating blizzard update agent" only go 1/3 of the way and stay there... So I downloaded the game client from blizzard.net and started that up and it would show "updating blizzard launcher" go to 2/3 of the way and stay there... So Ive tried everything the trouble shooting say to do I made sure my work offline was unchecked... I set my secondary login to automatic... I configured my Lan settings... I renamed the launcher.... I set it to run as compatible with windows XP service pack 3... I set it to run as administrator... I disabled my antivirus.... I disabled my firewall... I used task manager to end the agent.exe process every time it failed... I would right click the launcher and select "run as administrator"... The game was never installed on this computer so there is no directory that requires deleting... And still nothing has worked at all for me... So let me get this straight. I bought a $60 game I can't even play... that was glitchy as all get out when it first released and had terrible game play and storyline compared to the first 2 Diablos. I can't even play this game without an internet connection let alone it will not even install with my system wide open to it and no one that works for blizzard has even tried to help trouble shoot this problem for 2 months now? This game is still on the shelf at wal-mart how? I really want my money back... and I would not be amazed if blizzard is getting swamped with law suits right now...Why did you have to release such an awful game? and pretty much ruin the Diablo series for me?
The easiest (and only way I know of) to deal with the issue you're having is to use the command window (cmd.exe). After you open the launcher and get the progress bar, type [ipconfig /release] (minus the []) and hit Enter.

The launcher should then open. When it does, go back into your command window and type [ipconfig /renew] (again, minus the []). Your launcher should then allow you to play.

Hopefully Blizzard can find a permanent solution in the near future. =/
I've been plagued with this problem for months. I'm unable to launch D3 and SC2 for days or weeks at a time,interspersed with random periods where the games will inexplicably work for a short period. Completely unacceptable for software I've paid $60 for.

I'd like to at least see an acknowledgement from Bliz in this thread that this is an issue.
So would the 'battlenet' folder that I'm supposed to delete possibly be named 'bnet' ? And would it be under C:// PROGRAMFILES/DIABLO3/BNET, instead of whatever the crap blizzard said it was supposed to be under?
Bump. Haven't been able to play for 2 days now. I mean it doesn't matter too much, because I just came back from a year long hiatus 3 days ago. Guess I'm done again.

Join the Conversation

Return to Forum