Digital purchase processed, no auction house

Mac Technical Support
I purchased diablo 3 through blizzard and the game works fine and I received an email saying my purchase has been processed and I now have access to the auction house and all the other features that should be available after the online purchase has been verified (they say it can take up to 72 hours to verify). 5 days later, still no access to any of the features that they say I should have after my purchase has been verified.
Have you hit the little "refresh balance" button at the top of the AH window (it looks like a little green circle consisting of two arrows)? I've run into a similar scenario before where the BNet balance didn't update until I hit that button.
what window?
ohhh the Auction house window. I cant even open the auction house
This is rediculous. It worked for about a week then decided to go back to saying that my online payment still hasnt been verified. its been 3 weeks since i payed for this game and it says it "could take approx. 72 hours"...
mine has done exaclty the same let me know if you have resovled it im still trying to work this out!
Same issue here, there seems to be no way to report this either.

----------------
Google to the rescue! A password change resolved the issue.
I had this issue I contacted customer service they said they resynced my account and had to change my password after doing fixed the problem.

Join the Conversation

Return to Forum