GTX 670 FTW Edition *Stutter Fixed* Detailed

Technical Support
So I've made several posts over the last few weeks about this game running fluid. I was pulling my hair out, and some of you may have read other threads already. I was getting stuttering no matter what I did with graphics settings. Tonight with experimenting on the NVIDIA Control Panel with 314.22 drivers, I've got this game running more fluid than I've ever seen since the beta. Running at 51-52C to boot. I'm going to share with you exactly what I have set, and I will make a few points as this may not work for every NVIDIA user with these drivers. So *DISCLAIMER* if you follow my steps, don't be angry with me if something worsens. A few notes before I get started:

1. I have a 60HZ monitor.
2. I have a custom fan curve using EVGA Precision X, which keeps my card cooler than you may register stock.
3. If you aren't aware, the 600 series I know FOR SURE throttles down at 70C. You want to try to avoid your card heating that high, though it's well within operating temperature. It will cause a performance hit due to throttle down. Thus my fan curve (which I can share if you wish).
4. I was playing solo.

Now on to the specific steps that has my game running 99% smooth:

1. First thing I did was search for "D3Prefs", which is a text file. I deleted that, because the game will make a new one with the default settings for your system when you start it. You can choose to do this, or not. I wanted a clean slate to eliminate factors, and use the recommended settings Diablo 3 set for my computer to handle. Go to the Start Menu, search programs and files for "D3Prefs". Trash it.

2. Now open "NIVIDA Settings" in the bottom right corner of your screen.
3. Go to the "Manage 3D Settings" tab on the left side column.
4. Select the "Program Settings" tab, leave "Global Settings" alone.
5. If Diablo 3 is not in the program drop down box, hit "Add" and put it there. Then select it so it shows in the drop down box as the current program.
6. Now in order I'm just going to list EXACTLY what mine looks like (would've been easier with screenshots I suppose). If your items show "Use Global Setting", and match what I say to turn on / off that is FINE. Leave it alone.

6a. Ambient Occlusion "Off"
6b. Anisotropic Filtering "Application-Controlled"
6c. Antialiasing - FXAA "On"
6d. Antialiasing - Gamma Correction "On"
6e. Antialiasing Mode "Application-Controlled"
6f. Antialiasing Setting "Application-Controlled"
6g. Antialiasing Transparency "Off"
6h. CUDA - GPUs "All"
6i. Maximum Pre-rendered frames "4"
6j. Multi-display/mixed-GPU acceleration "Single Display Performance Mode" (Note I only have 1 card / 1 display. So this may change if you additional displays).
6k. Power Management Mode "Prefer Maximum Performance"
6l. Texture Filtering - Anisotropic sample optimization "On"
6m. Texture Filtering - Negative LOD bias "Allow"
6n. Texture Filtering - Quality "Quality"
6o. Texture Filtering - Trilinear Optimization "On"
6p. Threaded Optimization "Auto"
6q. Triple Buffering "On"
6r. Vertical sync "Use 3D Application Settings"

*MAKE SURE* you hit "Apply" in the bottom right corner to be safe (even though it will prompt you to save when you exit). In addition to all of the above mentioned, I did defragment my hard drive with Diablo 3 on it. If you have never done this since you put Diablo 3 on your computer, be sure to at least give it a go for that extra bump.

Now in game there are a few things to change with your new settings applied. Be sure V-sync is checked, and the foreground / background sliders are unchecked. There is no reason to have both on as v-sync locks your frames to whatever your monitor refresh is anyways. Other than that, I left everything as Diablo 3 recommended which was entirely maxed with the exception of Shadows, they were set to "Medium Smooth". For me it was "voila!". Never seen it play so smoothly. If it doesn't work for you, then I apologize but I wanted to share if I could help! There you have it, the laundry list that got me excited.
Thank you very much for this awesome fix!

I own the same videocard and i was really upset with the game performance but now is so much better! it was like turning water into wine.

Thanks!!!

Best Regards,
Queiroz
Thanks for your trouble. I can regretfully confirm that this does not fix problems with my gtx680 though =(
Seems like Power Management Mode "Prefer Maximum Performance" option is doing a trick, had issues with some other games with PMM set to Adaptive.
07/09/2013 12:01 AMPosted by Callynn
Thanks for your trouble. I can regretfully confirm that this does not fix problems with my gtx680 though =(


yeah man! I have the same problem for a long time ONLY with this game (more than 1 year and a half). I have an gtx680 too, i7 2600k, 8gb ram corsair (trying with all clocks -> 1066-2000 MHz), 2 SSD Sata ( vertex 2 and corsair f1) and could never fix the performance issues, trying with all settings combinations, even all graphics to MIN and with others OS (XP, W7 and W8..).. the stuttering of this game sucks
Just confirming that this fix still worked for the following.

geforceGTX 660ti Drver 350.12
Windows 7.

I had the issue of the game stuttering every 5 seconds or so while in town with patch 2.2.0, which is fixed now. I still have minor freezing when going up against 50 plus mobs but I can leave with that.
I have a GTX 670 as well and have had the game complete crash/freeze up as a result of this stuttering. I applied the above fix and it worked great!

Give this man a cookie, as I can finally play D3 in something besides ultra low resolution!

Join the Conversation

Return to Forum