My launcher won't open "checking for updates"

Technical Support
I'm stuck at "Checking for Updates" in both my D3 launcher and SC2 launcher.

Played earlier just fine, shut down PC as normal.
Did a few errands, turn PC back on, now this.

Searched like crazy for similar issues, very few posts even had a helpful response, tried the things suggested in the few that did. Same issue still happening, can't even run the repair tool cause it is in the actual launcher that won't come up.
over an hour, tried every solution I could find, both blue posts and random people.

Still can not launch.
Can not play games.
Wasting my afternoon yelling at my computer.
Read lots of people have had this issue on and off for quite a while.
Multi-million dollar company needs to step it up.
Going to do something else before I lose my temper completely and break something over this second-rate launcher software I'm forced to use.
I've done everything recommended on all blizz forums, on the battle.net tech support sections and tried a few things I found through google.

Still can not get my launcher to launch. Now I get "Updating Blizzard Update Agent"
So far Blizz support for this issues seems severely lacking and pretty much every thread I've read through leaves ends with this problem unresolved...
guess it sucks to be a person with tech issues on the weekend...

tried a few more things, next step is to uninstall all blizz software if one last thing doesn't work.
Then I'll try to decide if its worth the hassle reinstalling when there is a good chance the problem will persist as it has for a few people who tried that to fix this issue.
Having the same problem. It gets stuck at 2/3 bar.
What do the error message say? For me, I fixed one problem then a different error occurred. It took me a few hours to mess with it before it actually worked.
any reply please, I have the same issue!!!!
Try to update the Adobe Flash Player, as the launcher uses it, and if it isn't up to date it can get stuck. The other thing I would recommend trying would be to have Internet Explorer opened up as well, when you launch the launcher.
Kraze has some great tips here. The list below, includes his as well as a few other you might want to try. Do so one at a time of course, so you can figure out what the problem is.

Patch Tips

There are quite a few things that can cause this:

-Ensure your firewall or antivirus software is not blocking the launcher. You may have to temporarily disable it.
-Ensure Internet Explorer can access the internet, even if you don't use it as a browser. Be sure it is not set to work in offline mode.
-Ensure you have the latest version of Flash for IE, even if you don’t use IE.
-If you are on a campus or public facility some will block P2P software which is what Blizzard uses. In the launcher tools menu you can disable P2P, although this will slow patching time.
-Ensure Secondary Login service is enabled https://us.battle.net/support/en/article/enabling-windows-secondary-logon-service
-Ensure you are running as Admin https://us.battle.net/support/en/article/run-in-administrator-mode
-Some third party software can interfere with the launcher so you can try running in Safe mode with Networking enabled. Beware your antivirus will be off if you do this.
- Sometimes odd things work such a DNS flush https://us.battle.net/support/en/article/ip-release-renew-and-flush-dns

If those do not work, you can try deleting the Battle.net Tools and Cache folders to clear any corrupt files

https://us.battle.net/support/en/article/deleting-the-battlenet-cache-folder-pc
https://us.battle.net/support/en/article/deleting-battlenet-tools-folder-pc

https://us.battle.net/support/en/article/disable-proxy-settings
Proxy Fix
Via Barthas -WoW

Control Panel -> (Network and Internet) -> Internet options -> Connections tab -> LAN Settings and uncheck Automatically detect settings.
A similar step by step by Blizzard:
https://us.battle.net/support/en/article/disable-proxy-settings

If "Automatically detect settings" is already unchecked, enable it, then open Internet Explorer(regardless of what browser you normally use), load a website, go back there and this time, uncheck that option and leave it unchecked.
You could try this, it bypasses the launcher, but may not fix your problem. It is the typical way that I launch the game though. It's a tad faster.

Open Explorer.exe. (Your file manager)

Navigate to the Diablo III installation folder.

Right Click on "Diablo III.exe".

Select Create Shortcut from the context menu.

Right Click the "Shortcut to Diablo III.exe".

Select Properties from the Context Menu.

Add to the box that says "Target" a space and " -launch"

That is [Space][Minus]launch after the last quote.

You'll likely get something that looks like this.

[ "C:\Program Files (x86)\Diablo III\Diablo III.exe" -launch ]
why is the launcher even necessary? its design and implementation is awful
this is bull !@#$ none of these fixes helped me. WHY CAN"T I BY PASS THIS STUPID SECONDARY PROGRAM TO PLAY MY BLIZZARD GAMES???
You need to install the Battle.net App first.

edit: it's in the sticky:

http://us.battle.net/d3/en/forum/topic/11746194516

Join the Conversation

Return to Forum