Game stuck at startup seeing closed gates

Technical Support
Prev 1 2 3 5 Next
Same with me
Mac OSX Mavericks Here. re-installed. tried out of fullscreen and in fullscreen mode. I recently got a "time scale" button overlayed on the top left. But when I either run the app directly or through the launcher I sit at the closed gates lock screen.

Fully updated, OSx Updated, re-installed & restarted, all to no avail
bump... still happening...
Bump it up. I would really like to play in Beta...
I am having exactly the same problem. Can't get into game at all after hitting play button and have to go to Task Manager to close the program.
Same problem, Windows 7 only way to get out is to crt alt del and end process.
I'm having the same issue. I let the screen sit there for 5 minutes and still nothing. I Ctrl+Alt+Del and find the process has stopped responding. It's not for lack of RAM, though the Battle Net app does eat up a lot of unnecessary RAM. I think the biggest problem is that when you're at the screen of the doors there is no way to know if it's just taking a while to load or if it's stuck. There's no loading bar or anything that gives an indication. Please help us all fix this. I just got my Beta Key today and was psyched to play, cause my wife's had her key for weeks now (no I'm not bitter j/k) and now the game is locking up on me. I am currently using Windows 7 on a laptop that plays WoW, Starcraft and Diablo with no issues so Hearthstone should not be an issue. Thank you for your time.
I guess I am experiencing the same things. I thought it was because I am in China.
Same here! Installed the game a couple of days ago and keep getting stuck at closed gates. However, I installed the game on both my brother's and my sister's computer (HP notebook and MacPro) and the game actually worked. I guess it is probably related to hardware/software combinations...
Filed a bug report in the corresponding section, maybe you guys can add to it?

Good luck!
Okay guys I solved the issue for my machine. I poked around Blizzard Support pages for general games and found this:

https://us.battle.net/support/en/article/shutting-down-background-applications

I went in there and shut down a bunch of programs that were running that didn't need to be. Then I also went and turned off a lot of programs that were launching at startup that didn't need to be. I launched HS and it worked! And it's continued to work so I hope this helps you all.
just installed it...and...same problem here...I watched cinematic, but in menu when it says "click to start" I hit it with one click but nothing happened...chatting with friends is working also I see menu button (can quit the game, etc)...
Happening to me also on windows 8
Same but i done 3 fights and at next one i get stuck and
I have this issue too
Me too....
I get stuck after click to start...
Same as above. Where is support? Is it a server related problem?
Windows 7
My game stuck after I click to start it
same problem here. :(

and i was SO happy when i got my key...

Join the Conversation

Return to Forum