Stuck on "Starting Game" Screen

Mac Technical Support
This is really frustrating... I'll play a game, then after EVERY game I play, when I go to play another, it will be stuck on the "Starting Game" screen (Where it says random things like "staring at inn keeper" while it's loading). It just keeps loading a new phrase until it finally says, "There was an error starting your game. Please wait a few minutes and try again."

I've tried clearing the cache by deleting the blizzard file in C:\ProgramData\
I've tried scan and repair on the launcher.
I've tried restarting my computer...

Nothing works. I can play one game and then it does this.

Any ideas?
I even tried uninstalling and re installing the game... Nothing is working.
Same thing happened to me now. I'm running OS X 10.8.5. Is it the client or are servers down?
The servers aren't down. I was able to play several PvP games... It's only when I try to go in practice mode. I might be able to play ONCE... Then it does that, literally every single time. I have to quit game, and try again... sometimes several times just to play once. It's REALLY frustrating.
Same for me, for two days now. Windows 7 64-bit, all the menu's are working, but the game gets stuck on endless "Starting game" messages.
This problem started for me today and I haven't been able to play a single game practice or proper play. It just gets stuck on different phrases or generating the error message. Needless to say I have restarted the game and computer countless times. Problem persists :(

I'm on a Macbook Air with Mac OS X version 10.7.5
There's a "Breaking News" panel in in the app now saying that some people can't access certain modes of play, presumably Training/Practice, and they're working on fixing it.
Same thing is still happening. Mine is stuck doing the "bribing guards", "tightening hinges", etc. stuff right now.
İs your problem fixed ? i have still same problem cannot play...
I have the same problem, Game is stuck on "Starting Game" Screen.

Join the Conversation

Return to Forum