Hearthstone Time Out at Start

Mac Technical Support

I'm using a mac and my copy of hearthstone times out when it starts, basically the front screen opens with the closed doors, then the screen fades to black with just the armored glove cursor, my friends list in the bottom left and the menu in the bottom right.

Next the screen goes back to the closed doors and the doors have a notice saying
"Your game timed out as it was requesting data from the Hearthstone utility service. Please relaunch Hearthstone to connect."

Weird because it was working this morning, and I've reinstalled and uninstalled and still it doesn't work. I did leave the game on by accident for the day - could that have been it :-S.

Let me know what you guys think or if anyone is having the same problems!
I got the same problem on my Mac and it happened 30 minutes ago also ...
I don't know how but the problem solved by itself
10/28/2013 02:15 PMPosted by Snootch
I don't know how but the problem solved by itself


I wish my problem would solve itself.

I see multiple topics on a similar issue of the game just got getting to the tutorial, and thus, no free deck, and cannot battle.
I've got the same problem. Suddenly it stopped working.
I'm having the same problem. I just got my beta invite and I haven't gotten to play the game because of this :(
Me too i did the scan and repair but nothing changed... nothing need repairing
Same problem here. Black screen with armored glove, then the glove changes to the progress cursor, the "beach volley ball", and I need to force quit the app to return to finder. Received the beta today, but haven't played yet due to this.
Same error for me: The Hearthstone application starts, take over the screen, displays the closed doors and briefly turns the mouse cursor the armoured glove before the beach ball of death starts spinning endlessly. I need to CMD-Tab out of the application and kill it from the OS X dock, which lists the application as not responding via the app icon's context menu.
Experiencing the same thing. Worked for a good week or so, and as of the last few days, whenever I launch, The game opens to the BETA gates, fades to black, friends list is working and accessible (so are options) and then it loads the gates again saying that I timed out, and sends me back to the desktop.

Happens no matter how I launch it. Tried uninstalling it and bliz launcher, tried removing all left over files too, didn't work.

Any suggestions?
Someone please help I have the same problem and I am not sure what to do.

Join the Conversation

Return to Forum