"Closed: The game was unable to log you"

Mac Technical Support
Same here .I cant log in can you help?
Same here. I can not start the game since around 3 1/2 months. I tried everything. It is a "little bit annoying" ^^. Im use my mobilephone as a mobile hotspot to get my internet.
I am having this problem too. I open the battle net launcher, press the "play" button for hearthstone, and the hearthstone app opens but the screen says "closed the game was unable to log you in through battle.net. please wait a few minutes and try again." This has been happening for at least the past three days (I only started play again three days ago, the last time i played before then was during the closed beta). OCCASIONALLY the game will actually work, however after a few games I will be in the middle of a match and the turn won't end, or I start a match and get stuck on the replacing your starting cards screen for 15 minutes before i force quit, and then can't log back on.
I have tried deleting the cache and repairing client and nether have solved this issue.

Diablo and starcraft both still work.

The computer I am using is OS X 10.8.4, and i have tried with firewall both on and then off.

new things i did as i typed this:

I just turned firewall off again and quit the battle net launcher and started it back up- and the game loaded properly. i then closed the game and tried to reopen it again straight away without changing anything, and i got the same error message as before saying "closed the game was unable to log you in through battle.net. please wait a few minutes and try again."

another thing i noticed when i closed and reopened the battle net launcher right before it actually worked is that as it was loading up a smaller window with my log in details appeared first, and then was replaced by the usual screen. most times i open the battle net launcher i don't see this. (i would still like to point out however, when it was working i then closed hearthstone and NOT the battlenet launcher, and then the game would not work on reopening from the same instance of the battlenet launcher as before. so it may be a launcher problem, but this makes it seem unlikely:l)
Same here :(
Donpablow, can you create a new thread, and post some more information about your connection?


Rate me! https://www.surveymonkey.com/s/Velnrak

Join the Conversation

Return to Forum