Disconnecting from Hearthstone and Battle.net

Mac Technical Support
I have recently joined the beta and I really enjoy it. Well for the most times at least. I keep disconnecting from the game which makes it very frustrating. As i'm new to the game, 150 gold is a lot for me. Getting 2 out of 3 losses in the Arena because of disconnections is just painful.

I have checked everything I could and read all the troubleshooting support tips.

Is this a known issue in the beta? Maybe for Mac OS in particular?

Any help would be appreciated.
happening to me frequently as well
Same thing is happening to me. This is EXTREMELY frustrating.

Just happened to me a few minutes ago in the arena. Actually drafted a great deck, crushing my opponent, about to win and then boom, disconnect. It's infuriating.

Now as if that wasn't bad enough, upon relaunching the game it shows a loss. Quite frankly, it's bull**** (pardon the strong language, but it is). I understand this is beta and server hiccups are going to happen, which is fine, but when it's our hard earned gold and CASH on the line, these types of problems are unacceptable.

Server problems will happen, sure. But for something like the arena where money is being spent, it would be prudent for the default behavior NOT to give a loss. If you're worried about disconnect abuse, build in some tracking and punish repeat disconnectors, but don't punish the masses by default for the actions of a potential few.
I have the same problems here, and it happens fairly often recently. It is very frustrating, especially in Arena plays.
forgot to mention, it actually happened three times in a roll to me when I was play Arena :(

Blizzard please fix it; otherwise, I don't think I would spend real money or gold in Arena anymore.
Yesterday It was fine but then it's happening
This occasionally happens on some nights, then a few days later the problem is gone.

Worst connection system of all online games. Ever.

And that's quite a feat.
I have the same issue, with the connection dropping, on average once per hour.
Same exact problem, its so frustrating, especially on the games u were going to win 100%
Disconnected from 5-6 games in a row.
I am still trying to ignore this issue, but it's impossible. I just disconnected right before the winning blow in the Arena, literally while I was dragging my minion for the kill. Hearthstone just decided that I should lose this match instead... Awesome!

How about some assistance here, Bliz? I see several topics on this issue and clearly I am not the only one. We are talking about a game mode where you can actually spend real money to play. Then how come there is no help to get here? The troubleshooting tips are not helping either and I have no problems playing any other online games. It's still beta, yes. But again, some people are paying money to be able to play a round in Arena hence they deserve at least some kind of answer.
01/27/2014 11:24 AMPosted by RobaL86
I am still trying to ignore this issue, but it's impossible. I just disconnected right before the winning blow in the Arena, literally while I was dragging my minion for the kill. Hearthstone just decided that I should lose this match instead... Awesome!

How about some assistance here, Bliz? I see several topics on this issue and clearly I am not the only one. We are talking about a game mode where you can actually spend real money to play. Then how come there is no help to get here? The troubleshooting tips are not helping either and I have no problems playing any other online games. It's still beta, yes. But again, some people are paying money to be able to play a round in Arena hence they deserve at least some kind of answer.


At the VERY LEAST, don't count disconnects as losses in Arena mode.
I wonder when Blizz will address this...
same here!

is this a mac specific issue?
is there any response by blizzard so far?
I don't think it's just mac.

I'm suffering the same problem on PC atm. I literally can't get through one game without getting disconnected from battle.net. Like you guys, my net connection is fine, I can play any other online game, the troubleshooting doesn't work, it's just randomly started happening today again (was fine yesterday) etc. I had a look on forums, and it seems to be happening to a lot of people. So not just a Mac issue.

Haven't found anything remotely helpful or responsive from Blizz which is frustrating. Beta is Beta and bugs/glitches are to be expected. But this is terrible .. a bug is one thing, but not being able to connect to the game consistently while wasting people's currency and giving no definitive response to what's going on is another.

Worst connection system of all online games. Ever. And that's quite a feat.


^^
ditto ^ blizzard you need to sort this, i was addicted to the game but i don't think i will play until this is fixed, over the last few days it's become worse, i think in the last 6 games i've played i was able to finish 2.... it's boring now quite frankly, whats the point in playing when even when you trounce them you get auto loss as you're about to win.
same here
This happens a lot to me as well. If i'm lucky and I don't disconnect I end up skipping a turn. I hope blizzard fixes this because right now the issue makes the game almost unplayable. The issue is also not related to my internet.
I installed the game on my Mac a few days ago and I was very impressed with how smoothly it was running. Now, all of a sudden I am getting these "unable to connect to battle.net" messages. I'm usually unable to load into the game, but when I can, it always crashes on me just a few minutes later. Please fix this soon Bliz, I was having a blast. Are there maybe connection issues right now because of an upcoming patch? Thanks for any responses/advice.

Join the Conversation

Return to Forum