Not getting through the startup screen

Mac Technical Support
I've only played the game once, a few days ago, and it worked without problem then. When I'm trying now however it doesn't get past the startup screen. If I keep waiting I then get a message saying
Closed. Your game timed out as it was requesting data from the Hearthstone utility. Please relaunch Hearthstone to reconnect

I tried relaunching and restarting my computer and try again, but I'm getting the same thing all the time. Anyone knows what's up?
In the same situation...Is the server down or smth?
Same here. Some friends have the same issue.
anyone tried reinstalling?
same problem here
Okay, now getting the "Playful Sprites" issue instead.
I have the same issue right now.
yup...switched to the playful spirits...
I can confirm the same issue
Same here
Same here, tried both restarting pc and reinstalling the game, nothing works… Id guess servers down?
The same for me : impossible to go after the start screen. Worked perfectly fine two days ago
Same thing here on Mac. I just played this game not 10 min ago on my PC, so it seems this is mac related.

I did although play on this Mac yesterday, so its super odd, since there hasn't been a patch between yesterday and now.

Fix plx
Same here

Join the Conversation

Return to Forum