For those having FPS lag

Technical Support
AMD has released a new hotfix that has fixed my going from 60 fps to 1-2 fps.

http://www.tcmagazine.com/tcm/downloads/31698/catalyst-1010e-hotfix

not from official site, i get an error on AMD site, but this site also has the download. 100% clean and works(otherwise I wouldn't be posting here :D)
Performance optimizations for systems with an AMD Radeon HD 6870 and AMD Radeon HD 6850 series of graphics products installed


...

Star Craft 2 performance enhancements


...

Download and install the AMD Catalyst hotfix from the following location:

AMD Catalyst 10.10e Hotfix for Windows® 7


http://support.amd.com/la/kbarticles/Pages/GPU87AMDCat1010eHotfix.aspx

Thanks much Bobhlead! This will help for a lot of people.

EDIT: And, yeah, file download for 10.10e hotfix gives a "file not found" error like you said. Haha
It works for all the HD series seeing as I was having problems with a 5570, so its not limited to the 6000 series
It won't necessarily optimize Starcraft II on "all HD series" but only on the specified cards (for example, 'increasing' the maximum/medium 'work' of a card). However as with any new CCC driver it will reset your settings (be it corrupt or incorrect) and Starcraft II was lucky enough to register it, fixing your GPU load drop.
It won't necessarily optimize Starcraft II on "all HD series" but only on the specified cards (for example, 'increasing' the maximum/medium 'work' of a card). However as with any new CCC driver it will reset your settings (be it corrupt or incorrect) and Starcraft II was lucky enough to register it, fixing your GPU load drop.


I'm just happy I can play again. I was moved back 16 positions from 3rd in my platinum league, now i have to reclimb ladder to get back to my 3rd place spot.

Join the Conversation

Return to Forum