No campaign option or online bug?

Been playing starcraft for awhile, everything was fine, I'm now currently stationed in japan. was running fine in the usa. when i open starcraft i only get the region option, I've tried reinstalling the game and I've always tried all the regions. i don't get a campaign option, and when i type in my name, nothing happens. it wont let me click on anything. Please help your fellow gamer.
Hello Jbliink.

Gonna start with the easier questions first:

  • When you say "i only get the region option", exactly what do you mean? Are no other options displaying, or are all other buttons greyed out?
  • Are you using the StarCraft II patcher client to open the game (and login in-game) or are you using the Desktop App?
  • When you say that you "don't get a campaign option", are you saying that you are unable to login and thus unable to play the campaign, or that you can login but you can't play the campaign specifically?
  • Hopefully we can get this sorted out.

    Mathmick - Most Valuable Poster - The Most Valuable Poster program info

    In other news, local has earned the award for "Most time wasted reading webcomics", more later.

    Join the Conversation

    Return to Forum