Game crashing after short game play time

Technical Support
My system specs are
ATI Radeon HD4650 video card
4 gigs of ram
AMD phenom 9950 2.9GHz quad core processor

and i've been having a problem where on any graphics setting medium and higher the game will crash after playing for about 10 minutes in single player, and I haven't even been able to load a multi player game at all. Sometimes the whole computer will reset, and sometimes the game will just stop responding, and I can close it through task manager without having to reboot. I have downloaded the latest drivers for my video card prior to running the game at all and i'm just completely stumped as to what could be wrong.
Also here is the DxDiag info
------------------
System Information
------------------
Time of this report: 7/27/2010, 07:11:31
Machine name: AJAY-AAF9CB6A8A
Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.090804-1435)
Language: English (Regional Setting: English)
System Manufacturer: BIOSTAR Group
System Model: TA790GX XE
BIOS: Default System BIOS
Processor: AMD Phenom(tm) 9950 Quad-Core Processor, MMX, 3DNow (4 CPUs), ~3.0GHz
Memory: 3328MB RAM
Page File: 446MB used, 4764MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.5512 32bit Unicode
DxDiag Previously: Crashed in DirectShow (stage 1)

---------------
Display Devices
---------------
Card name: ATI Radeon HD 4600 Series
Manufacturer: ATI Technologies Inc.
Chip type: ATI Radeon Graphics Processor (0x9498)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_9498&SUBSYS_E930174B&REV_00
Display Memory: 1024.0 MB
Current Mode: 1024 x 768 (32 bit) (60Hz)
Monitor: Plug and Play Monitor
Monitor Max Res: 1600,1200
Driver Name: ati2dvag.dll
Driver Version: 6.14.0010.7101 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
Driver Date/Size: 7/6/2010 20:47:56, 299520 bytes
WHQL Logo'd: Yes
WHQL Date Stamp: n/a
VDD: n/a
Mini VDD: ati2mtag.sys
Mini VDD Date: 7/6/2010 21:27:52, 5069312 bytes
Device Identifier: {D7B71EE2-D7D8-11CF-466F-3AC9A1C2CB35}
Vendor ID: 0x1002
Device ID: 0x9498
SubSys ID: 0xE930174B
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel: ModeMPEG2_C ModeMPEG2_D
Deinterlace Caps: {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
{3C5323C1-6FB7-44F5-9081-056BF2EE449D}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{552C0DAD-CCBC-420B-83C8-74943CF9F1A6}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
DDraw Test Result: Not run
strangely im experiencing the same problem with the same card
Same Problem
The game crashes only in CS and in Jayray's Bar
------------------
System Information
------------------
Time of this report: 7/27/2010, 10:21:53
Machine name: APHRODISIAK-PC
Operating System: Windows 7 Édition Familiale Premium 64-bit (6.1, Build 7600) (7600.win7_gdr.100226-1909)
Language: French (Regional Setting: French)
System Manufacturer: System manufacturer
System Model: P5QL PRO
BIOS: BIOS Date: 11/28/08 17:25:18 Ver: 08.00.14
Processor: Intel(R) Core(TM)2 Quad CPU Q8300 @ 2.50GHz (4 CPUs), ~2.5GHz
Memory: 4096MB RAM
Available OS Memory: 4096MB RAM
Page File: 1370MB used, 6818MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7600.16385 64bit Unicode
---------------
Display Devices
---------------
Card name: ATI Radeon HD 4800 Series
Manufacturer: ATI Technologies Inc.
Chip type: ATI display adapter (0x944C)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_944C&SUBSYS_02801043&REV_00
Display Memory: 2297 MB
Dedicated Memory: 506 MB
Shared Memory: 1791 MB
Current Mode: 1680 x 1050 (32 bit) (59Hz)
Monitor Name: Moniteur Plug-and-Play générique
Monitor Model: CMC 22 W
Monitor Id: CMO2228
Native Mode: 1680 x 1050(p) (59.954Hz)
Output Type: HD15
Driver Name: atiumd64.dll,atidxx64.dll,atiumdag,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Driver File Version: 8.14.0010.0678 (English)
Driver Version: 8.632.1.2000
DDI Version: 10.1
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
Driver Date/Size: 8/18/2009 03:15:58, 4059648 bytes
WHQL Logo'd: Yes
The game crashes only in CS and in Jayray's Bar, never happened yet during a game
strangely im experiencing the same problem with the same card


Glad i'm not alone, I got the game at midnight and wasn't even able to play it till almost 4am due to installation issues then the game play stuff started happening.
I noticed that the original poster is using DirectX 9. The latest version is DirectX 11. Try updating it.
Well for my case Direct X is updated and still crashes wheter i am still in the menu or in campaign
I just picked up the game, installed it just fine, same problem happened to me in the beta on my dekstop, got to test on my laptop though.

Now it's launch day, picked up the game and bam, 10 minutes in, computer hangs, have to do a hard reset. All settings are on high/ultra. My video card is a 9600 gt so it's not the same problem as the radeons.

I have yet to lower the settings, that'll be my next test, however, I'd like to find out why it's happening to some people and not others, possibly a bug that carried over or a conflict with the system?
Same issue is happening with with me. I am using a Radeon 3870 with AMD phenom x4 940. It did it 4 times. On the fourth a box came up saying the installation was corrupt and it ran a repair tool. Haven't tried it since then yet.
Having a similar issue, Nvidia 9800 GTX, AMD dual core 6400 3.2GHz, 2GB RAM, Window XP.

DirectX 9 too, but I don't think you can update to 10/11 unless you have Vista/Window 7 respectivly...

I found that, in my case at least, setting the Affinity for SC2 to run on one core delayed the crash/freeze. Also, I did not have this problem at all in beta until Beta Patch #16.
I guess someone didn't find the solution yet. well I try i updated every last of my driver including direct X. I close the quick cam cause apparently it can cause unexpected shutdown. I open the same port that are suggested for wow and put the game on loooow. Am out of idea and i don't think it because of my computer.

Operating System:(windows vista)
Windows 2.6.0.6002 (Service Pack 2)
CPU Type:
Intel® Core™2 Quad CPU Q8200 @ 2.33GHz
CPU Speed (GHz):
2.36
System Memory (GB):
8
Video Card Model:
ATI Radeon HD 4650
Video Card Driver:
atiumdag.dll
same problem. brand new computer, brand new copy of the game.

specs:

Windows 7 Premium(64)
Intel Core i7 1.6 ghz q720
ATI Radeon 5870

Installed newest video drivers, direct x, and all that

someone help us!!!

Join the Conversation

Return to Forum