Sc2 taking 100% cpu when dlding information.

Technical Support
I am using a Intel(R) Core(TM) i5-4670 CPU @ 3.40GHz, which is well above the minimum specs for this game. But the problem shouldn't be effecting my cpu, whenever i login, when downloading the information for the main menu news, 100% cpu. Dlding map information/map names 100% cpu. Player information, 100% cpu. Anything that the game has to pull information from the internet for, eats my cpu. Whenever it happens, my pc degrades to almost unusable untill it stops, my vent goes up to 20k ping, skype stops working, everything slows to a crawl untill its done. Most of the time if I go to DL a map to play on the arcade, it doesn't even let me because it disconnects from battle.net. No other game or software on my computer causes anything like this to happen. For example, the game Crysis 3, barely eats up 50% on the highest settings possible.
I have the exactly the same problem too..
A temporary fix i'm using, is i downloaded a free program that lets me limit the cpu usage of games. Called Process lasso. I limited sc2 down to below 50%, and it runs fine now, with no issues. Which means its taking 100% of the cpu for no reasons at all...
You limit the process to 1 core affinity ?

Still, process lasso is not working for me.

Anyone with a real solution ? I cant even play, so mad
It seems like this problem would still exist, at least for me.

ive got 100% cpu ussage while I load the menu or download Arcade maps. (ive got a Intel Pentium 2130)

Is there any solution to this problem yet?
I have the same problem as op i5 2500k
Same problem on i5-3570k

Edit: Selected scan and fix. Don't know why it took me so long to find it, but that fixed it.

Edit 2: It started again. Apparently Scan and Fix did not work.
Just upgraded to an i5-4690k and exact same bug, what gives? Anyone at all worked out a way to fix this? Game is unplayable, definitely won't be able to buy LOTV after this...
Same problem here :/

And the game was running perfectly not so long ago on the same CPU
Sounds like this isn't a problem that's isolated to only a few people. Has anyone found a permanent fix yet or gotten any help from Blizzard?
Great tip with Process Lasso. I was experiencing the same issue, set Process Lasso to run SC2 in High Performance and it's no longer using 100%.
Same problem, I just set affinity in Task manager to only use 3 of 4 cores and it works fine now.

Join the Conversation

Return to Forum