Battle.net application problem.

Technical Support
Hi, For some reason with the App i can not seem to get Starcraft 2 to start it already tells me that the game is running but doesn't show up in my task manager. I am unable to start it through the app but i can start it using SC2Switcher through the Directory... I have uninstalled and reinstalled the App i have tried to cancel the Agent Update.exe i really don't want to re install startcraft 2.

I can run other various games through the application just not starcraft 2 If i try to start it without the battle.net and by itself it tells me SC2 is already running even off a fresh restart of my computer. Running Windows 8.1 April Update.
Hi Bezziie,

This is currently a known issue with the Battle.net App, and one that our QA team believes it has pinned down. Deleting your Agent.db file should get you all fixed up.

With the game and desktop app closed,
1.) Hit Windows+R to open the Run dialog
2.) Copy/paste the following: C:\ProgramData\
3.) Open Battle.net > Agent, and then delete the agent.db file.
4.) Run the app again and allow itself to update.

You can find Mac instructions on that process here, if needed: http://us.battle.net/support/article/6141
______________________________
Technical Support: Sunday-Thursday, 12pm - 9pm Pacific Time
How am I doing? // https://www.surveymonkey.com/s/Glaxigrav \\
Thank you very much that fixed it. That was very annoying saved me from reinstalling starcraft 2.
Hello Auron, I believe this can also be caused by a 3rd party application that is interfering with the normal functioning of the launcher (such as VirtuMVP for example). I'd try booting into Selective Startup mode and see if that helps.

Selective Startup
https://us.battle.net/support/en/article/shutting-down-background-applications
i'm having same problem and the above deletion of the battle.net cache isn't working for me. anyone else have a way to play this game?
Hi Geo, can you try these suggestions, and let us know how it goes?
________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak

"They say the oaks are just too lofty
And they grab up all the light."
Same problem here... I did remove the agent.db several times and locate the game folder files (include restarting my pc too). but when i click `play` button the status just changed into "Game is running" but the starcraft windows never pop out while the process SC2.exe is running on my windows task manager.

Any help?
I think i found the problem.. I have the application named Lucid Virtu MVP Control Panel and the Starcraft 2 is checked on the list.

Just uncheck and all good.

Hope this help.
:)
Can you boot into a Selective Startup, and see if that helps?
________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak

"They say the oaks are just too lofty
And they grab up all the light."

Join the Conversation

Return to Forum