Updating Blizzard Update Agent Stuck Error

Technical Support
I have not played Starcraft II in a while, and this annoying problem happened again. Whenever I start up Starcraft II, the Blizzard Update Agent progress bar gets stuck around 30-40%. I tried doing everything on the support page in addition to other solutions that I have seen on similar discussions. The only thing that seemed to work was the Selective Start-Up method. However, identifying the problematic system service is a pain so far and I want to know if there is a better/more convenient solution. Is there any simple fix to this?

A message to any Support Forum Agents:
Why does this problem keep on happening? I have noticed that this problem always occurs whenever I don't play Starcraft II for long periods of time. It's a pain to keep on trying to fix it every single time.
Selective startup fixed the problem? I'd recommend to just keep running in selective startup and adding in 2-3 things at a time until you have everything on that you want on or until you find the problem.

The other two things I'd do would be to delete these

Make sure to back them up just incase though. Although if selective startup fixed the problem then I don't think those will be necessary.

Thank you for your reply!

I just fired up my computer on normal start-up, and I tried running Starcraft II to see if the problem was still there. Note: (I did not finish identifying the problematic system service) Miraculously, it worked? The only thing that was strange was that the patch notes could not load. Instead, the window had:

HTTP Status 404 - /en-us/sc2/patch

type Status report
message /en-us/sc2/patch
description The requested resource is not available

Apache Tomcat/ 7.0.34

How did this problem solved itself? I have no clue. I'm just glad it's solved. Thanks for the help!
I also continue to have this issue were the agent gets stuck on about 30 to 40% and I have also followed the instructions online and it seems that the only way to correct is to reinstalling. There must be a better solution for this, even disable all firewalls, deleted battle.net folder and issue persist. Any one have any more ideas or solutions?
Well after messing with it for several day I finally got it to work, not entirely sure which of all the steps I took finally resolved the issue, however I think the developers might want to look into this problem and see what is causing it and perhaps do a patch or something.

The one time it worked was just a fluke. The problem is still at large for me.

The thing I have been noticing is that Starcraft II only works for me on a luck basis. This morning, I was able to run it and log in to my account. (Albeit, barely, the maps did not load, so I had to exit the program) When I tried to run SC II again, the progress bar would become stuck.

If I find something that works, I'll post it right away.

Note: Deleting the battle-net folder did absolutely nothing for me and from reading similar forums, did absolutely nothing for others.
Hmm... could you try all the steps in here and see if it fixes the problem?
KillerofGods - Care bear poster of 2014
Newbies Guide to StarCraft: http://us.battle.net/sc2/en/forum/topic/9882048889
Fan made Heroes FAQ: http://us.battle.net/heroes/en/forum/topic/12090869473

Tried all of those steps to no avail.

I found one temporary solution that'll work for people if this error has only happened recently.
Launch the game without the (annoying) launcher:

For Windows:

Go to this folder --> C:\Program Files (x86)\StarCraft II\Support
and click on SC2Switcher.exe

This will allow you to bypass the launcher error and run Starcraft II directly.

Note: This is only a temporary solution. If the game version is out of date, you will not be able to connect with the servers. If anyone has a link to download new patches as they come out, that'll be great.

I finally got it to work. I'm not sure if this is the general solution, but it definitely helped me. I hope it does for anyone with this problem.

Delete Internet Explorer Method
For Windows Vista/Windows 7:
1. Click on Start > Control Panel > Programs > Unistall a Program
2. On the Left Column, click "View Installed Updates"
3. Under the "Microsoft Windows" section, right click on Internet Explorer, and click uninstall
4. After uninstallation is complete, restart your computer.
5. After reboot, right click on SCII, and click "Run as Administrator"

Note: I'm not sure why this worked. If someone can explain this, that'll be great. If not, that's cool too.
I read on other forums and on the battle.net support page that Internet Explorer was pretty buggy with SC II, especially with the LAN settings (proxy servers), etc. I tried the steps the support page recommended with no effective result. (Out of blind fury), I just deleted Internet Explorer, and viola! It worked.

Unfortunately, I don't think this method works for Mac users, judging by how OSX doesn't even have IE (sorry!)
Glad you found a fix that is working for you TokiDoki. :)

Also thanks for sharing your solution, it may help other users in the future.

The problem happened again as soon as I restarted my computer. Windows automatically reinstalls IE on boot-up. (Thanks Microsoft)

However, while I was playing around with the launcher this past month, I found out something very interesting.

I did a "Windows Network Diagnostics" and came across this error:

"Either the Peer Name Resolution Protocol service (PNRPsvc) or the Peer Networking Identity Manager service (p2pimsvc) is not running"

I fixed this issue, and suddenly, Starcraft II was working like a charm. It has worked consistently for me so far. :)

DELETE idstore.sst METHOD
For Windows Vista/Windows 7:
1. Click on Start > Computer > Local Disk (C:) > Windows > ServiceProfiles > LocalService > AppData > Roaming >Peer Networking
2. Delete corrupted idstore.sst file
3. After deletion is complete, restart your computer
4. After reboot, right click on SCII, and click "Run as Administrator"

The folder "Appdata" is hidden, so you have to change your view options to view hidden files.
For Windows Vista/Windows 7:
1. Open "Windows Explorer" window
2. Click Organize (Should be on the top left)
3, Access "Folder and search options"
4. Click on "View" tab
5. Click "Show hidden files, folders, and drives"
6. Click "Apply" and then click "OK"

Another way to view the Appdata folder is to use the run option:
For Windows Vista/Windows 7:
1. Click on "Start"
2. Search "Run", and press enter
3. Type in "appdata" and press enter
4, Appdata folder should appear, and continue step 1 of "Delete idstore.sst Method"

I hope this helps anyone who is dealing with this problem. Happy gaming!


Join the Conversation

Return to Forum