Broken SC2

Technical Support
So at first I started getting random "sc2master_unknown_mmq" messages. Now I can't go to 1v1 or 2v2. Restarted my system and still no luck.
Same issue, its telling me I need to upgrade my version of sc2
Same as above.
Happened to me too.
same issue
My guess: They attempted a backend upgrade. It failed. Now there are a few poor build team members scrambling to try and roll the servers back but something is going wrong.

The Blizzard team probably hasn't issued a public statement yet. It will probably say, "Well dang it, a random odd event occurred and we are attempting to fix the issue. Please be patient and try not to break the keyboard while we bring up the servers."
I do not see the 1v1 and 2v2 tab as well.

Edit: 4v4 is gone as well.
So much for my one night of freedom. Guess its back to sleep.
It's gone for me when choosing NA. If i switch to EU i still see the options...
Me too. It only shows 3v3 and that doesn't even work
Having the same problem...
Same problem as well. Any info is much appreciated.
Same for me. Logged out, shut down, restarted, still no luck. Except now.. Its all blank and where the "Play" button is there is a lock. When I hover the mouse over it it says I need to upgrade my copy of sc2. It makes no sense.
No no no Blizzard, you made this addiction in me and then one friday night don´t let me play!!!! NO. I need to play right now!!!
I feel the frustration just as all of you, I was hoping for one good relaxing night of 4vs4 with some relaxing music.

Unfortunately it has all been ruined by everything posted above and a whole of others.
Happens from time to time, just switch regions while you wait for it to resolve.

Join the Conversation

Return to Forum