Can't access 1v1 2v2 or 4v4

Technical Support
Post Limit:
Thanks for the response, no luck so far with that trick, just getting no buttons and the play button has a lock on it with the phrase when highlighted "In order to access this content you must upgrade your copy of SC2"
05/31/2014 02:36 AMPosted by xoxoRomance
Thanks for the response, no luck so far with that trick, just getting no buttons and the play button has a lock on it with the phrase when highlighted "In order to access this content you must upgrade your copy of SC2"

Hmm okay thanks for the response. There currently is a bug that has the matchmaking buttons mess up and I wasn't sure if they were related. From the sounds of it, it looks like they aren't related. Thanks for the info!! :D
05/31/2014 01:46 AMPosted by todespolka
05/31/2014 12:22 AMPosted by Jay
The only matchmaking issue is that I still don't have an option to disable matchups.
For god's sake, why the !@#$ do I have to play ZvZ in unranked?????


Just leave the game. Is it that difficult ? Its unranked ! it doesnt count !


it counts it destroys my unranked MMR. So I get bad opponents in the other matchups which is annoying for me and them and pretty unfair towards them.
The game is saying i need to upgrade my copy of sc2 but I have been playing hots for months now and played three days ago. I can go to EU server and it lets me play but NA thinks i do not of hots for some reason. It still shows that i am in gold and rank 14 and but will not let me play. My other account is also doing the same thing. I guess its time to ladder on the other servers for today.
05/31/2014 05:44 AMPosted by Jay
05/31/2014 01:46 AMPosted by todespolka
...

Just leave the game. Is it that difficult ? Its unranked ! it doesnt count !


it counts it destroys my unranked MMR. So I get bad opponents in the other matchups which is annoying for me and them and pretty unfair towards them.


You can't be serious. Your account doesn't even have 25 games and has never done a single placement in any mode. Either you're posting from an alternate account or you're really that weird.
I'm having the same issue.
hope they fix this issue soon
05/31/2014 01:47 AMPosted by KillerofGods
05/31/2014 01:31 AMPosted by xoxoRomance
Any new update? Just got off work and have a few hours to kill - think this will be back up tonight?

If this is the issue I think it is then try looking at this post and see if the workaround it mentions helps you at all.
05/07/2014 02:09 PMPosted by Leviathan
What you are seeing is a known issue that Bliz is looking into as we speak:
http://us.battle.net/sc2/en/forum/topic/11985408642#3

So far there are two community devised workarounds:
1) When logging into the game, wait on the main screen (Kerrigan/Hyperion/planets) for a little while and let the client get all its connections to battlenet stabilized. (Let the adds in the upper right load up, let your league border load up, etc.) Then click over to the Matchmaking screen.
2) Log out and back in. It may not work every time, but it usually works in a few tries.


thank you! worked for me!
I'm getting this exact issue again tonight. Only sometimes instead of the buttons missing, it actually is typed out like Two Versus Two, etc. But the Play button is grayed out regardless.
Same as Bonewalker.
Instead of 1v1 I see it spelled out One versus One.
NA server.

I tried Scan and Repair utility, and have tried a few times over the last few hours.

Edit: As one of the Blizzard posts stated, different region is okay. EU is working.
I see various problems. Sometimes I get the 1v1, 2v2, 3v3, 4v4 spelled out. Sometimes some types are missing. Sometimes I can't pick a race. It's been going on for months.

Join the Conversation