An error occurred while starting SC2 plea...

Technical Support
an error occurred while starting starcraft 2, please try again.


I've been playing sc2 for about 3 years, this randomly started happening to me. I didn't know if it was from the new app being installed, the SC2 Updates, or the fact that my Gaming Laptop has Nvidia's GEForce Experience program that updates my drivers/game settings.

I tried many things after looking up every forum i could find about this problem. Nothing worked. For some reason, cutting and pasting the entire SC2 folder worked....

Go to OS (C:) drive, open "Program Files (x86)" , and cut the entire "Starcraft II" folder.
Go back to your OS (C:) drive, and open "Program Files" without the x86.
Paste the entire "Starcraft II" folder into "Program Files" and try running the game again.

This worked for me, but know that i found many others who fixed the problem by doing other things... None of which worked for me.

I"ve been trying to fix this for about a week now with no avail. Thank goodness i found a 4 year old post that recommended doing this Cut and Paste business or i would have never been able to play SC2 again. Thanks to whoever posted that on some random website lol.

maybe Blizzard could give us some insight as to why that would have happened to my computer out of the blue? (i've used this laptop for at least a year now with this game. kind of odd for SC2 to randomly crap out on me? )

* is sc2 now running in 64 bit ?
* why is my computer allowing the game to run in this folder?

thanks in advance. Hope this helps everyone else who has this problem.


Join the Conversation

Return to Forum