The StarCraft II Performance Guide For Macs

Mac Technical Support
Prev 1 8 9 10 15 Next
As there aren't many post about the 2009 MacBook Pro with 9400m, I'm going to write about my expirience with it.

In the firts and second beta phases I was running the game on medium shaders and it was playable (20-30pfs). Then when the game lunched I barely could play with every thing on low; I was running mac os 10.6.4.

I downgrade to 10.6.3 and I got a lot better, I could not push the shaders to medium but some other settings on high and got 30 pfs across the board.

When the leopard graphics update kick in I went back to 10.6.4 and the game runs just as it did in 10.6.3

Today I decided to try win 7 on boot camp. The game default to medium shaders, and the cinematics run smoothly at 60pfs, but the campaing was not playable, got to turn down almost at the same levels set in mac os 10.6.4 with SnowLeopard Graphics update.

IMO, is better to stay with Snow Leopard now, the small improvment you get from bootcamp is not worth the hassel of getting win 7 in you mac. And now with the update 10.6.4 is the same as 10.6.3

Hope this helps teh few out there running teh game in a macbook pro with 9400m.

Sorry about my spelling and grammar, english is not my native language.

Frost, regarding "2-B. The Macbook Pro, Mid 2010 15/17-inch Core i5/i7 Macbook Pro with 256MB or 512MB nVidia GT330M Graphics Card" where you claim to get an average of 50 fps, can you provide more information about the computer you tested this on?

What is the native resolution of this computer's screen?
How much RAM does it have?
How much video RAM does it have?
Plus anything else you can think of that might be important.

I'm unable to get more than 30 fps when I use the settings you provided. See the earlier post from me, http://us.battle.net/sc2/en/forum/topic/224842575?page=8#158

I'm wondering if there's a non-StarCraft system setting somewhere that you or I may have set that causes this difference in performance.

Thanks.
I’ve already mentioned this in pieces over the course of the thread, but I have the 15” Core i7 Macbook Pro, 2.66Ghz, 512mb VRAM GT330, 4GB RAM, 1680x1050 high res upgrade. Running at it’s native resolution on 10.6.4 with the Graphics Update.

Basically the stock high end 15” MBP. No aftermarket upgrade. No changes other than installing the game and messing with the graphics options inside.

The tests I run are 2v2 and 4v4 against hard CPU’s on Lost Temple, Delta Quadrant, Tempest, and Lava Flow. Four of the most taxing maps with shadows and reflections.

Seriously. I get 50fps on average, It starts at about 65fps at the start of the game, and decreases to 45-55 once the match heats up with the exact settings listed.

I’m seeing all the posts with people getting much lower fps than at the settings I posted. But my work gives me access to most all of these machines, and they all played as described.

I’m genuinely confused as to why other people are having trouble.
Thanks for replying, Frost. That's all great information. I'm going to look into this some more to see if I can determine if there's something else I'm doing that is affecting the frame rate.
The only thing I can think of at this point is the ambient temps of the room the computers are in. OS X will usually automatically throttle back the GPU if it can’t keep it cool enough. I live in the northern part of the U.S. where it’s rarely above 65ºF 3 seasons out of the year, and almost always 65º indoors year round.

While I’m playing SC2, the CPU and GPU temps hardly ever go above 160ºF. I wonder if you guys are just letting the Macs get too hot.
You could be onto something. Temperature might be an issue.

I've noticed, and I'm not sure why this happens exactly, but the longer the game is on the worse the performance gets.

I have the 330M and happen to be in the same boat as Atomic and Winter (not getting the frame rates suggest by the guide and getting the lower ones)

For me personally, I can get:
50FPS
1152x720
High textures
High graphics

By the fourth game though, I'll be getting like 35 FPS at the start instead. It's so odd. There's just so many inconsistencies with this damn game. I hope it gets cleaned up soon. I mean, a lot of us are playing on top of the line Macs here.

EDIT: Just throwing out my thanks to you Frost for doin all this. I'd imagine it's a real pain in the ass. Keep up the good work and as a group we'll keep trying to pin point all our optimization issues.
Indeed we will. Having a strong, knowledgeable community on the boards tends to go a long way towards getting to the bottom of things.

A lot of the patches on the WoW Mac client came from research done by the Mac community over there. And that was the ultimate goal of this thread, to help build the same kind of trust with the userbase here.

Here’s to a productive decade with Starcraft 2.
After searching around the forums and net I've found a couple ways that increased my fps with my 08 iMac that may help others. I saw, like others, that game performance slowly degraded over time due to heat issues so I downloaded smcfancontrol. It automatically set my fan speeds and keeps my temp 10º C cooler. I also edited the variables.txt so that shadows were completely off. After this I was able to run SC2 on the listed settings and got great results. Averaging about 40 fps but load times are a bit (~20 seconds) longer.
I can't wait to only be able to play Starcraft 2 in the winter when I'm freezing my ass off!
By then, Blizzard will have probably fixed the major issues.
@ Robrueda, I have a 2009 MBP 9400m playing with with medium textures, shaders and high model at a consistent 30s to mid 40s fps under 10.6.4. Check out this guide. http://segmentnext.com/2010/08/07/starcraft-2-graphics-performance-tweak-guide/ It helped me adjust my settings to play on medium shaders without compromising gameplay. Maybe it might help you as well.
Frost, I also have the 15-inch MacBook Pro, 2.66 GHz Core i7, 4 GB RAM, 512 VRAM and Hi-Res screen and I don't get anywhere near your performance in the single player campaign (I don't do multiplayer). I have 10.6.4 and the Graphics Update.

In the first 2 missions, I just get between 25 and 35 fps with about 20 units on screen. I'm using the exact settings you described in the first post of this thread.

Is there any kind of information I should post to help diagnose the problem?
I have a late 2008 macbook pro. 2.53Ghz, 4GB of ram, and I am using the 9600M GT. Framerates are fine while playing other than the fact it constantly bounces between ~40 and ~5. I don't know why but it will constantly cycle between those two numbers. I will start out at about 40 then it will drop to ~5 then back up to ~40. It will do this like clockwork without a pause or hesitation. When I watch the frame rate counter it will cycle through all the intervening numbers. Performance does not change if I am in a battle or just looking at empty ground. I have tried setting up as the thread advised. I have also tried the advise in the "gain ~20 fps" thread.

I have tried with the 9400M in my laptop and it looks terrible, but it runs at a constant fps rate. Is this a problem with the 9600M GT drivers or is there something I can do to fix this?
@Kuroi, thanks a lot man but I just got burn by all the options. Could you please send me your variable.txt file to robrueda@gmail.com so I could just repleace mine?

Thank you in advance.
@Kuroi, could you post the whole thing here? I would like to see that as well.
An update:

(I have a 2010 MacBook Pro, 2.66 GHz Intel Core i7, 8 GB RAM, NVIDIA GeForce GT 330M 512 MB, 1440x852, Mac OS X 10.6.4 with latest updates as of August 20, 2010 and have been getting 30 FPS instead of the suggested 50 FPS. Lately I have been using 2v2 all Terran Lost Temple for tests.)

I tried disabling all my Mac OS X login items, which included Growl, Google Notifier, iTunes Helper, Backblaze, a Razer mouse utility, an HP printer utility, and an Adobe update utility.

I tried creating a new account, on the theory that it would not have accumulated as much configuration baggage.

I tried disabling automatic graphic switching, so the NVIDIA GPU would always be active.

I tried disabling Time Machine.

A friend related that in an unrelated context under Windows, he experienced GPU performance degradation when using special debugging graphics drivers. It occurred to me that I have Xcode installed, and have run Apple's OpenGL Profiler in the past. I removed ~/.MacOSX/environment.plist which was causing the environment variable GL_ENABLE_DEBUG_ATTACH to get set to YES, and rebooted, so this environment variable is no longer set.

I tried disabling Spaces.

None of the above had any effect on the frame rate.

I have posted the Variables.txt file I've been using at http://traipse.com/Variables.txt

Frost, if you have time, it'd be interesting if you tried my Variables.txt file on your 2010 MacBook Pro, and/or post your Variables.txt from that computer and I could try it on my computer. If either of us experienced a change in performance, we could diff the files.

Thanks for all the effort you've put into investigating this issue.
Here's my Variables.txt

alphadepthWrite=1
aolight=0
creepnormalmap=0
creepQuality=0
creepreflection=0
creepselfshadow=0
creeptrans=0
deff=0
deffspec=0
depthDisp=0
displayflyerhelper=All
displaymode=2
displayunitstatus=All
dof=0
dragscrollspeed=1
fogvolume=0
foliagedensity=0.000000
foliagequality=0
frameratecap=60
frameratecapGlue=30
gamehdr8bit=1
gamma=1.092000
GraphicsOptionEffectsDetail=0
GraphicsOptionLightingQuality=0
GraphicsOptionModelQuality=2
GraphicsOptionMovies=0
GraphicsOptionOverallQualityVer7[5]=4
GraphicsOptionPhysicsQuality=0
GraphicsOptionPortraits=1
GraphicsOptionPostProcessing=0
GraphicsOptionReflections=0
GraphicsOptionShaderDetail=1
GraphicsOptionShadowQuality=0
GraphicsOptionTerrainQuality=0
GraphicsOptionTextureQuality[2]=1
halo=0
hdr=1
hdr8bit=1
height=720
hotkeyprofile=2_GridLeftSide
LastChallengeId=RushDefense
lastDeviceId=2147
lightingLevel=0
lightmap=1
lightmapcastshadows=0
localao=0
localeidassets=ARco
localeiddata=ARco
localight=0
localShadows=0
lowqualitymodels=0
lowQualityMovies=1
mousescrollenabled=1
mousescrollspeed=30
mousesensitivity=0.500000
mousewheelzoomenabled=1
MoviesSeen=1
music=1
MusicHeard=1
normalmap=0
parallax=0
parallaxshadow=0
particlelod=0
particleobjects=0.000000
particleterrain=0.000000
physicsdensity=0
pixellight=1
portraits3d=0
preBlendedCreep=1
preferWindowedFullscreen=0
profanityfilter=1
reducemouselagenabled=0
ribbonlod=0
sampleFOW=0
shadowmapsize=128
shadows=0
simplifiedCloaking=0
simplifiedShaders=0
soft=0
softshadows=0
softshadowTaps=6
SoundAutoDetectCPUCoreCount=2
soundchannels=32
soundoutput=Default
SoundQuality=1
spec=1
splatlod=0
systemutilitykeysdisabled=1
targettexeldensity=0.560000
TerrainTextureHiResCacheSize=24
TerrainTextureLowResCacheSize=50
TerrainTextureSize=128
texQualityLevel=1
texSpace[2]=640
textureBasedFOW=1
transparentshadows=0
treadlod=0
useLowqualitymodels=0
voicechatmode=1
voicechatsoftwaremute=0
vsync=0
watercaustics=0
waterflipbook=1
waterreflection=0
waterrendertargetformat=0
waterrendertargetsize=128
watershadow=0
width=1172
windowheight=720
windowx=121
windowy=44


If you want higher fps, set hdr and spec to 0 and change the resolution to 1172x720. If you play on win7 bootcamped, you can push the settings a little more without losing performance.
Frost, if you have time, it'd be interesting if you tried my Variables.txt file on your 2010 MacBook Pro, and/or post your Variables.txt from that computer and I could try it on my computer. If either of us experienced a change in performance, we could diff the files.

Thanks for all the effort you've put into investigating this issue.


After looking at each text file carefully, The ONLY difference I can see between the two, other than the last challenge mission played line, is that you don’t have your framerate capped at all. It’s possible that your Macbook Pro’s simply working too hard, and OS X is throttling the GPU back, resulting in lower overall framerate.

Our variables are otherwise exactly the same, from HDR to creep quality to shaders.
I used SMCFanControl on my older Macbook Pro with the older ATI X1600, but I haven’t used it on my newer machine. Mainly because I got this thing right when it was introduced, and SMCFanControl hadn’t been updated for the Core i7’s yet.

But as time went on and I watched the temps on the new machine, I decided that the new Core i7 MBP keeps itself pretty cool on its own as long as I cap the framerates of whatever game I’m playing.

So no, I don’t personally use it anymore. Partly because near the end of my older MBP’s life, I had to have the fans replaced because I used them on max constantly. But that was a much hotter running machine.

I don’t really recommend against using it, but I don’t really use it because this machine runs cooler on its own.

Join the Conversation

Return to Forum